Free Web Hosting Forum

Free Web Hosting Forum (http://www.000webhost.com/forum/index.php)
-   Customer Assistance (http://www.000webhost.com/forum/forumdisplay.php?f=6)
-   -   wordpress: 404 error on new page/post (http://www.000webhost.com/forum/showthread.php?t=2972)

mardie 08-15-2008 12:54 AM

wordpress: 404 error on new page/post
 
Ok I successfully installed wordpress on my testing site. Then I added a new post/page, and is there, you can see the post/ pages in the site. However, when you click any post title or page it would say "Error 404 - The Webpage cannot be found".. Is there something wrong?

Oh the site location is:
http://mardie.site88.net/testing-site/

Thank you in advance :)

Bad Karma[CORE] 08-15-2008 06:29 AM

did you make any changes to the permalinks option or the .htaccess file ?

Jordan 08-15-2008 09:19 AM

Yes he did see http://www.000webhost.com/forum/cust...-htaccess.html

mardie 08-20-2008 12:52 AM

well if you know wordpress. there is this "all in one seo" plugin that could change the permalinks.. oh well, ill just not use it, besides its just a test site..

And JJbit, i saw that post, thanks.

DIYer 01-12-2009 11:16 PM

Spot On Bad Karma!
 
As always, your cryptic clues really work!

If you make changes to your Permalinks, which is recommended, you have to ensure the .htaccess is writeable (CHMOD 777), else you have to update the .htaccess file manually.

For other newbies installing Wordpress (mine is v2.7), if you post new Pages to your new Blog but can't click or access them, resulting in a 'not found" or 404 error, ensure your .htaccess file is present in your default blog directory, write enabled or manually updated with your new Permalink settings!

fireworking 01-13-2009 01:52 AM

Learn htaccess and update the CHMOD everything to 777 and I think it will work. Just make sure it is for the right package.

gxjenkins 05-24-2009 01:56 PM

This seems like just what is happening to me. I installed the Blog last night and everything was working fine.
This morning I can run the blog
http://lpsandmore.com/blog
But none of the links, or pages are working. I'm getting 404 errors. I checked using filezilla for htaccess file, but none were found.

Any idea what I should try next?

Thanks,
Gary

P.S. I deactivated All In One SEO and deleted the plugin files.

Bad Karma[CORE] 05-24-2009 04:30 PM

put a .htaccess file inside your /blog directory that contains these lines of code
Code:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>


gxjenkins 05-24-2009 06:05 PM

Quote:

Originally Posted by Bad Karma[CORE] (Post 49195)
put a .htaccess file inside your /blog directory that contains these lines of code
Code:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>


I created a text file with those lines and gave it .htaccess name with 777, and then 666 rights, but none of it worked.

Is there anything else I can try?

Gary

Bad Karma[CORE] 05-24-2009 08:48 PM

In the AdminCP of Wordpress go to Settings - Permalinks and under Common Settings select Default as option. Then save the settings and reload your website and check the links. This should let you know whether the problem is down to .htaccess or not


All times are GMT. The time now is 03:07 PM.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.