Free Web Hosting Forum
Go Back   Free Web Hosting Forum > 000WebHost Services > Customer Assistance
Reload this Page wordpress: 404 error on new page/post
Reply
 
Thread Tools Display Modes
(#1)
Old
mardie mardie is offline
Junior Member
mardie is on a distinguished road
 
Posts: 5
Join Date: Aug 2008
Default wordpress: 404 error on new page/post - 08-15-2008, 01:54 AM

Ok I successfully installed wordpress on my testing site. Then I added a new post/page, and is there, you can see the post/ pages in the site. However, when you click any post title or page it would say "Error 404 - The Webpage cannot be found".. Is there something wrong?

Oh the site location is:
http://mardie.site88.net/testing-site/

Thank you in advance


Creative Designs by Mardie - sorry, under construction

Last edited by mardie; 08-15-2008 at 01:55 AM. Reason: add more info
Reply With Quote
(#2)
Old
Bad Karma[CORE]'s Avatar
Bad Karma[CORE] Bad Karma[CORE] is online now
333 - only half evil
Bad Karma[CORE] is on a distinguished road
 
Posts: 6,944
Join Date: May 2008
Default 08-15-2008, 07:29 AM

did you make any changes to the permalinks option or the .htaccess file ?


Get in touch with me

Reply With Quote
(#3)
Old
Jordan's Avatar
Jordan Jordan is offline
Senior Member
Jordan is on a distinguished road
 
Posts: 1,860
Join Date: May 2008
Send a message via AIM to Jordan Send a message via MSN to Jordan
Default 08-15-2008, 10:19 AM

Yes he did see http://www.000webhost.com/forum/cust...-htaccess.html


~Jordan

Bye
Reply With Quote
(#4)
Old
mardie mardie is offline
Junior Member
mardie is on a distinguished road
 
Posts: 5
Join Date: Aug 2008
Default 08-20-2008, 01:52 AM

well if you know wordpress. there is this "all in one seo" plugin that could change the permalinks.. oh well, ill just not use it, besides its just a test site..

And JJbit, i saw that post, thanks.


Creative Designs by Mardie - sorry, under construction
Reply With Quote
(#5)
Old
DIYer's Avatar
DIYer DIYer is offline
Junior Member
DIYer is on a distinguished road
 
Posts: 22
Join Date: Jan 2009
Default Spot On Bad Karma! - 01-13-2009, 12:16 AM

As always, your cryptic clues really work!

If you make changes to your Permalinks, which is recommended, you have to ensure the .htaccess is writeable (CHMOD 777), else you have to update the .htaccess file manually.

For other newbies installing Wordpress (mine is v2.7), if you post new Pages to your new Blog but can't click or access them, resulting in a 'not found" or 404 error, ensure your .htaccess file is present in your default blog directory, write enabled or manually updated with your new Permalink settings!
Reply With Quote
(#6)
Old
fireworking fireworking is offline
Member
fireworking is on a distinguished road
 
Posts: 83
Join Date: Dec 2008
Default 01-13-2009, 02:52 AM

Learn htaccess and update the CHMOD everything to 777 and I think it will work. Just make sure it is for the right package.


Get traffic really easily
This is no scam. I have gotten 8,000 unique visitors in the last month with this.
(Get 100 free points when you get 100 points)
Reply With Quote
(#7)
Old
gxjenkins gxjenkins is offline
Junior Member
gxjenkins is on a distinguished road
 
Posts: 7
Join Date: May 2009
Default 05-24-2009, 02:56 PM

This seems like just what is happening to me. I installed the Blog last night and everything was working fine.
This morning I can run the blog
http://lpsandmore.com/blog
But none of the links, or pages are working. I'm getting 404 errors. I checked using filezilla for htaccess file, but none were found.

Any idea what I should try next?

Thanks,
Gary

P.S. I deactivated All In One SEO and deleted the plugin files.


"Its not over until you quit, so DON'T"
Visit Marketing Software Group Blog
Visit Gary's Odd Stuff II Store
Reply With Quote
(#8)
Old
Bad Karma[CORE]'s Avatar
Bad Karma[CORE] Bad Karma[CORE] is online now
333 - only half evil
Bad Karma[CORE] is on a distinguished road
 
Posts: 6,944
Join Date: May 2008
Default 05-24-2009, 05:30 PM

put a .htaccess file inside your /blog directory that contains these lines of code
Code:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>


Get in touch with me

Reply With Quote
(#9)
Old
gxjenkins gxjenkins is offline
Junior Member
gxjenkins is on a distinguished road
 
Posts: 7
Join Date: May 2009
Default 05-24-2009, 07:05 PM

Quote:
Originally Posted by Bad Karma[CORE] View Post
put a .htaccess file inside your /blog directory that contains these lines of code
Code:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
I created a text file with those lines and gave it .htaccess name with 777, and then 666 rights, but none of it worked.

Is there anything else I can try?

Gary


"Its not over until you quit, so DON'T"
Visit Marketing Software Group Blog
Visit Gary's Odd Stuff II Store
Reply With Quote
(#10)
Old
Bad Karma[CORE]'s Avatar
Bad Karma[CORE] Bad Karma[CORE] is online now
333 - only half evil
Bad Karma[CORE] is on a distinguished road
 
Posts: 6,944
Join Date: May 2008
Default 05-24-2009, 09:48 PM

In the AdminCP of Wordpress go to Settings - Permalinks and under Common Settings select Default as option. Then save the settings and reload your website and check the links. This should let you know whether the problem is down to .htaccess or not


Get in touch with me

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com