Certificate problem


#1

Hello,

thank you for your great support and hosting. I’m really pleased with everything here…

However I’m facing a problem when I try to open my site. In Chrome I get this:

NET::ERR_CERT_COMMON_NAME_INVALID

I’m using htaccess file to force https protocol, and when I try to open my site, I got this error first…I’m able to “proceed” as unsafe and open the page.

Is there any workaround? What I need to do?

Thanks.


#2

What is your domain name??


#3

Hi bockey!

If http://grab-acre.000webhostapp.com is the website in question, I have corrected the .htaccess for you :wink:


#4

My domain name is uniwebhostingprevara.com

I saw you corrected .htaccess file, but this account is not associated with this domain. However, I copied your lines to my .htaccess file and I still get this:

This server could not prove that it is www.uniwebhostingprevara.com; its security certificate is from *.000webhostapp.com. This may be caused by a misconfiguration or an attacker intercepting your connection.

My account is:

enduring-street.000webhostapp.com

Thanks!


#5

@bockey Sry you can’t use “https” for custom domain like “www.uniwebhostingprevara.com”.
But you use “https” for your *.000webhostapp.com url’s…due to shared ssl.

If you want to use “https” for your custom domain then connect it with cloudflare(which provides free SSL).
Follow below tutorial if your want ssl.


#6

Thanks for your post. I will give a try and let you know!

Btw, nice tutorial!!!


#7

Tutorial credits goes to @sulliops :slight_smile:


#8

I followed steps from the tutorial…however I still get the same window, but this time with different explanation:

uses an invalid security certificate. The certificate is only valid for the following names: sni47717.cloudflaressl.com, *.amz-redirect.xyz, *.andray.top, *.barlett.xyz, *.conradinterglobal.com, *.conradtransglobal.com, *.cooncome.com, *.hauzoftr.com, *.hdboxmovie.net, *.inkhelp.xyz, *.inmersivos.es, *.kandicegaustad.xyz, *.nationtalk.ca, *.nationtalkdev1.com, *.nationtalkdev3.com, *.onvent.com, *.pentapka.top, *.scuolacomo.com, *.stevensross.com, *.truemfilesu1n.cf, *.vietlang-artshouse.com, *.winsblack.com, amz-redirect.xyz, andray.top, barlett.xyz, conradinterglobal.com, conradtransglobal.com, cooncome.com, hauzoftr.com, hdboxmovie.net, inkhelp.xyz, inmersivos.es, kandicegaustad.xyz, nationtalk.ca, nationtalkdev1.com, nationtalkdev3.com, onvent.com, pentapka.top, scuolacomo.com, stevensross.com, truemfilesu1n.cf, vietlang-artshouse.com, winsblack.com
Error code: SSL_ERROR_BAD_CERT_DOMAIN

What I did wrong? Should I keep lines in .htaccess file?

From cloudflare:


#9

From webhost:


#10

@bockey Its takes some time for SSL to get fully activated.
Just try again in some time. :slight_smile:


#11

I’m concerned because firefox says:

The page isn’t redirecting properly,

while chrome says:

redirected you too many times
ERR_TOO_MANY_REDIRECTS

So I’m afraid that I screwed something else…


#12

There is something causing the infinite redirect loop. I will investigate it.


Do you have any redirects configured from 000webhost cPanel > Settings > Redirects?


#13

No…there are no redirects.

maybe I screwed something with .htaccess or forcing the https.

Thank you for your efforts…I appreciate that !


#14

Are you using CloudFlare?


#15

Yes, he does …


#16

yes…here is the screenshot of DNS


#17

Go to the “Page Rules” tab and see if any are set up. That could be the issue


#18

I just checked. No rules…

I don’t know what I screwed…30mins ago the site opened (with “not secure” warning, but it opened)


#19

Try going to the “Cyrpto” tab and tell me what SSL is set to.


#20

@bockey Do you remember configuring anything from your website to use a specific URL?