FTP Clients getting disconnected every 20 seconds


Dear admins,

I am using a simple FTP client to upload files to my website. However, after uploading a file and waiting for about 20 seconds and trying to upload a second file, the status changes to “Working…” but never finishes. The only workaround for this issue is to disconnect and reconnect via my FTP Client every 20 seconds.

I have reproduced this behavior using different FTP clients on different operating systems / devices.

Here are my FTP settings:

account: tauronr.netii.net
host: files.000webhost.com
login: tauronr
password: password

mode: passive
security: none
port: 21
IPv6: “yes” (or “no”, it basically makes no difference anymore)

server encoding: UTF-8

It is worth mentioning that IPv4 connections are impossible most of the time. Only if I check the option “IPv6” I am able to upload a single file every 20 seconds before getting disconnected again.

I believe FTP Clients have never worked after you moved your servers. The file manager here works no problem, though.

This is inacceptable. I wish to be able using my FTP Client for uploading files as I am being offered this functionality on your website.

Please offer a solution for this problem.

Thank you.



@mantas.daraciunas can you check? :slight_smile:


@mantas.daraciunas Any day soon?


Dear @Rezombe,
Sorry for you inconvenience. However, I don’t see any problem from our side. I have connected to FTP using FileZilla and it worked perfectly fine.
What kind of ftp connection tool are you using? maybe the problem there?
Or it could be that your internet provider stops connection to out FTP servers.


Dear @mantas.daraciunas,

I was also suspecting my ISP being the root of the problem at first.
However, as mentioned in the OP I have tried connecting using different FTP clients in different locations, also using a mobile file manager.

These are the tools I frequently use:

  • FireFTP extension for Firefox
  • FX File Explorer for Android

I admit that Firefox is a very old browser, but both of these tools used to work just fine before you moved to Hostinger.

I did change my ISP somewhere in between but as I said the problem persists even if I am using mobile data on my phone.

I can test this again using a different FTP client on my home network (with the ISP in question) and using mobile data to try and identify which factor is causing the connection drops.

But my ISP offers an FTP server as well and I could use this no problem using my good old Firefox extension last time I tried.

I will try that again and report back in.

Could you confirm that my FTP settings are correct?
I remember that the host used to be different. Ever since you told me to change that I am experiencing these issues.

Thank you.



To login into FTP, use the details below. :wink:

Host: files.000webhost.com

Username: (the part before .000webhostapp.com)

Password: (Your website password)

I hope this helps you! :slight_smile:



This is exactly what I had written in my original post. Did you not read it prior to answering?

Sadly, this information is not helpful at all. I would appreciate it if you unmark it as the solution since it is not.

Thank you.



It isn’t marked as a solution. I was just showing you the steps to connecting via FTP to make sure you were doing everything right. :slight_smile:



I just unmarked it as a solution myself. Also, I merely asked for a confirmation that my FTP settings are correct as presented in my OP.
This did not require you to repeat them and consider it a solution. But thanks for the effort anyway.



Alright, but it seems to be working on my end?



Please restrain yourself from logging in using my credentials and posting screenshots of the root directories contents.

I request you to immediately delete that screenshot.

In future, use words to communicate. There is no need for screenshots.

And as always, your contribution is not helpful at all. So if you are unable to help, please just stop trying and let somebody else do it.

Thank you.



Please respect us, it’s a rule that must be respected. :slight_smile:


Also, I am here to help, and I can login, and have to login to your file manager in order to prove it works :slight_smile:



My speech was and is respectful. At no point did I curse or personally insult any members.

On the other hand, you openly posted the contents of a users subdirectory without his (my) consent.

This, my friend, is disrespectful behavior.

I understand that you might not have given it as much thought. But in future, please respect your customers privacy when attempting to help.

Thank you.



Alright, does the file manager work on your end?


I am currently at work. I will check it when I’ve got time.

I will keep you posted.



Alright, we’ll be waiting for a reply until then :wink:


Alright, I did some testing and here’s what I got:

  1. Now I cannot access my site “tauronr.netii.net” using FTP at all.
  2. My secondary website “tauronr.netai.net” is accessible through FTP and does not get disconencted after 20 seconds anymore!
Error message



All I did was turning off IPv6 support in my modem so my devices no longer get an IPv6 IP address assigned from my ISP in addition to the IPv4 address.

I do not think that turning off IPv6 changed anything though as now the problem is only solved for my secondary website whereas my primary website is not accessible at all using FTP.

I also just tested connecting to website 1. using my phone and mobile data and - it does not let me log in either. So this proves that the issue is neither ISP related nor does it have anything to do with the FTP clients I am using.

The problem is definitely server side.

This is rather frustrating.

Please tell me what you did while I wasn’t looking. :face_with_raised_eyebrow:


Tag-corner: @mantas.daraciunas, @ckhawand, @hexa


Can you try changing your ftp password?


No, the one I had before worked just fine.

In case you messed with the password, just change it back to what it was or tell me what you changed it to.

I turned IPv6 support back on just to confirm that this does nothing to the problem. Doing so brought back the problem on my secondary website.

  • I now cannot connect without using the option “IPv6” and the connection is lost after approximately 20 seconds time when I use IPv6.

My primary website remains inaccessible through FTP since yesterday.

Please check the IPv6 settings of your FTP server. The cause of the problem seems to be located here.

And don’t forget to fix the FTP password you seem to have changed for my main website.