How to fix: "Missing a temporary folder" and installed a new plugin


dear guys!
my free host used for a wordpress website. Every things is very good. But at yesterday, I made a new post, when I upload a new img I take a miss “Missing a temporary folder”.
I’m try to fix but I can’t.
I’m try to installed a new plugin but but I take a new proplem “PCLZIP_ERR_MISSING_FILE (-4)” and I can’t fix it.
What’s pro can help me! ple.!
thanks so much.


Can you screenshot the error you are getting?


Thank James, I know how do you say. But when I creat a new folder in wp-content I have new miss " ftp_mkdir(): 5 Kbytes used (0%) - authorized: 1024000 Kb". So, I can’t creat TEMP folder.
I checked the limit data in my host, but the data not limit any thing (Bandwidth: 428.36MB of 10000MB Disk: 231.99MB of 1000MB, Inodes: 11502 of 20000 , Sent email: 0 of 50).
So that, I can’t do to fix. So sad :frowning:
thank you for your reply to my question.


Can you screenshot what is happening?
I’ve opened my wp-config and created a folder called TEMP with no issue.

The message you’ve sent ftp_mkdir basically means it has been made?


I have the same problem, Wordpress says “missing a temporary folder” on upload, plus I cannot upload anything over ftp or create a folder !
It says :

ftp_put(): Can't open that file: Disk quota exceeded

Knowing I’m well bellow the disk space quota and inode quota, It just started happening yesterday !
Any solution ?


I can’t see where you guys are getting these errors, a screenshot would be awesome.

Use FileZilla or a better FTP client to try and creating directories etc.


there is a tutorial for this, let me know if that helped


Thank you for the answers. The problem is, we cannot create a folder nor upload a file using FTP, knowing that we have successfully logged on. It was working pretty normal until thing suddenly stopped functioning correctly and we get FTP errors saying that we’re over quota (which we’re not) ! here are some screenshots from WordPress, FileZilla and 000webhost file manager.

Upload from wordpress : (

Upload from filezilla (directory creation) (as you can see 8% inode usage and 2% disk space usage, and still saying over quota ??)

Uploading using 000webhost file manager; same error disk quota exceeded while uploading a simple image.

I believe it’s an FTP problem and not a wordpress issue, please help us with this.
Thank you.


Oh, that my problem. :frowning: help me too…!


Can you guys try an FTP client?

Or PM your details and I’ll attempt it.


I just sent a screenshot of the error using FileZilla…


Pm details over I’ll attempt it but not sure on a fix, tried enabling and disabling FTP in the control panel?


Just tried enabling/disabling FTP, no luck !
I PM’d the details !
Thank you.


Could you try this option please?


Yeah, I tried that, still no luck ! Same errors.


What does your say here sorry,


Here you go, It’s relatively new, I’ve only installed wordpress and written some posts !

Thank you


Hmm very odd. I’ve managed to make the TEMP folder within wp-content if you try the original reply up there about the TEMP issue and defining it within wp-config.php to see if this lets you continue with your script, and in the meantime I’ve sent this to a staff member to look at, confusing you cannot upload any files only rename/delete etc


I see that you renamed a folder in wp-content. Strangely I was able to modify wp-config.php and upload it back (overwrite) but the problem persists. It’s simply not possible to upload a new file. I hope we get a solution soon.
Thanks for the assistance.


Same problem here too !!!