How to remove en from the url


#1

I did not put in “en” in SEO setting how do I remove it

Sample url is here

http://primehouseproductions.com/en/open-air-wedding-photo-booth-rental/

en after .com is what I am talking about

Pleas help


#2

Hi, the problem you were experiencing was not a problem with your SEO settings, it was because you added a translations selector, and in doing so created the “English language”. Basically, Zyro was expecting you to add different languages and translate your pages, so it added “en” for the english pages.

Unless you plan on adding translations, I wouldn’t mess with that element. If you decide you do want to translate the pages, you really won’t have much of an option, as each language page will be preceded by the language code.

I fixed the issue for you and published the website, so now when you click on the pages, the “en” will not be an issue. If you try to visit those pages with the “en”, you’ll get a 404 error.


#3

Thank you that’s exactly what I wanted to do, thanks for taking care and publishing as well

How did you remove the translator thingy ? I went to the drop down options and it would not let me select no option


#4

What I did is I dragged a translator thingy to somewhere on the page and hovered over the “English” that has a star next to it, then clicked the “X” that shows up. Then just apply, and remove the translator thingy.


#5

Okay great

One more question if you don’t mind helping

On same url from first post, I added contact form at the bottom from 123contact form. When you load that url, it goes all the down, instead staying up on top

Any idea why it does that and how I can get it fixed thanks


#6

I apologize, I don’t see where the issue you describe is. Could you provide screenshots?


#7

Sulliops

Here is how you repeat it

Step 1: go to the below URL

Steps 2: go to menu, click Photo Booth
If you pay attention, for a micro seconds page shows top portion of the site, then immediately bring you all the way down of the page. Once you click, you should stay on top part of the page. Not automatically go at the bottom part of the page.

I am using 123contact form and not sure if that has anything to do with it.

You repeat this or desktop and mobile both.
Hope this helps! Thanks again for your help


#8

I see the issue, but I’m not sure if it has to do with the embed form. Try removing the form (copy the code of course) and publish the page, and see if it does it. If not, that’s the problem.