How to REMOVE webhost app extension?


#1

Hello!

I’ve tried and tried, but I can’t seem to figure this out, and maybe it’s an EASY solution (but I just can’t see it):

I have a domain name like this: MyDomainName.com

When it gets typed into the search bar, the domain pops up like this: MyDomainNamecom.000webhostapp.com

For Google AdWords purposes, I must remove the 000webhostapp.com from the URL.

Any advice?

Thanks!


#2

How have you setup yourdomain.com at the registrar?


#3

Yes, I have. Thanks!


#4

How have you done it?
CNAME?
Nameservers?


#5

I’ve done it with nameservers. My domain name company 1&1, tells me it’s done correctly on THEIR end, I just need to remove the 000webhostapp.com from the URL.

Thanks!


#6

Also, it’s maked as PARKED on my account. I’m “guessing” that has something to do with my problem.


#7

Within the control panel choose the top option under set web address and type torrancekitchenbathandflooring.com
Then once it resolves visiting torrancekitchenbathandflooring.com should bring up your 000webhost content but not display the unslightly address they provide.


#8

It shows up as https://torrancekitchenbathandflooringcom.000webhostapp.com/

Thanks!


#9

Thanks!

Trying it now.


#10


#11

Make sure to LINK site as well.


#12

It comes up as “domain already in use.”


#13

Done. No change. :slight_smile:


#14

Or may be you should chk your .htaccess file

May be you have mentioned this:-

RewriteEngine on
RewriteOptions inherit

RewriteCond %{HTTP_HOST} ^torrancekitchenbathandflooring.com$ [NC]
RewriteRule ^(.*)$ https://torrancekitchenbathandflooringcom.000webhostapp.com$1 [R=301,L]

Something like this…chk this once!!!


#15

Thanks - I’ll try that.


#16

Can you make sure to remove all records at your domain registrar?

Just have the nameservers setup ns01.000webhost.com and ns02.000webhost.com

You don’t need CNAME or anything else…

Make sure URL forwarding is off.


#17

I’ll try that NOW. Thanks!


#18

I tried and tried. 1&1 tells me that there’s is NOTHING wrong on their end – it’s a setting that has to be changed on 000webhost’s end.


#19

Okay as long as you point your nameservers and park your domain in the control panel the URL shouldn’t appear.


#20

omg wordpress?

Make sure your site URL torrancekitchenbathandflooring.com is in the settings please.