PHP Safe Mode?


#1

Ignore the question…already been explained at 000Webhost front page.

[COLOR=“Silver”]Is the Safe Mode on?.
I can’t install a script. The page keep redirecting to empty form and I get PHP error when loading the index.php.

If it’s on can I make request to turn it off?.

[/COLOR]


#2

According to http://www.000webhost.com/free-php-hosting
safe mode is off


#3

so, how do i make the safe mode on?


#4

Why would you want safe mode on?


#5

With safe mode off you have more limits than if safe mode was on :wink:

Soo… keep safe mode off :slight_smile:


#6

For safety sake :slight_smile: jk


#7

Hi,I ve read on 000.webhost.com that PHP Safety Mode was off,but I am still getting errors while running a PHP script:
1] Warning: set_time_limit() has been disabled for security reasons in /home…
2]Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/a8738537…
these 2 errors clearly state that PHP Safe Mode is on. I am running on server 34 and I would appreciate if you let me know whether administrators would turn it off for individual accounts??


#8

Safe mode will be removed in PHP 6, so don’t code after it, because your code will probely get wrong when PHP 6 come.


#9

when i m doing sms sending script then i m getting this problem

PHP Error Message

Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /home/a9206306/public_html/sms/alfa.curl.class.php on line 84

Free Web Hosting
SMS send sucessfully !

so how do i change safe_mode on


#10

In that case
safe mode = off
is better than its on?


#12