Rederct to http


#1

I want to redirect

https://example.com/index.php
to http://example.com/index.php

how can I do that please cuz am trying to use an iframe and it says you are trying to use the unsecured script and am sure it secure can someone help me fast, please


#2

Hi @AwadGorg

Set iframe’s src without https. Like
http://www.ex.com


#3

i did and the conent didnt show up the script didnt load


#4

this is the iframe

<iframe src="http://www.gameflare.com/embed/rise-of-champions/" frameborder="0" scrolling="no" width="700" height="530"></iframe>

#5

it didnt even show up in the message


#6

my site is running on https protocol I can put HTTP frame on it I need to change the protocol of the page to HTTP only this page while all other pages run in https


#7

this is the page URL https://gamehup.tk/rise-of-champions.php

like you can see the frame doesn’t appear in the page


#8

The url in the iframe was not found and made an 404 error.


#9

yea i waited too much time and no one answer so i just deleted it


#10

Hi @AwadGorg!

For those with other similar issues, we can deactivate the HTTPS redirect rules, however Google Chrome will redirect to HTTPS. Therefore we may need a header to overcome this problem. Please try the following method:

Please go to:

  1. Cloudflare cPanel > Crypto > Automatic HTTPS Rewrites > Off

  2. Cloudflare cPanel > Crypto > Always use HTTPS > Off

  3. Cloudflare cPanel > Crypto > SSL > Flexible

  4. Cloudflare cPanel > Page rules > Disable Always use HTTPS rule

  5. Go to File Manager > /public_html/.htaccess > Append the following code:
     
    Header set Strict-Transport-Security "max-age=0;"


#11

it said Application error
An error occurred in the website and your page could not be displayed. If you are the website owner, check your logs for details.

this is my htaccess file what is cuzing the problem

HTID:1827272: DO NOT REMOVE OR MODIFY THIS LINE AND THE LINES BELOW

php_value display_errors 1

DO NOT REMOVE OR MODIFY THIS LINE AND THE LINES ABOVE HTID:1827272:

IndexIgnore *
#Alternate default index pages
ErrorDocument 404 /404error.html
Strict-Transport-Security “max-age=0;”

display other default index page

Header set X-Frame-Options DENY

Header set X-Content-Type-Options nosniff

<FilesMatch “.(js|css|xml|gz)$”>
Header append Vary: Accept-Encoding


ExpiresActive on
ExpiresDefault                                      "access plus 1 month"

CSS

ExpiresByType text/css                              "access plus 1 month"

Data interchange

ExpiresByType application/atom+xml                  "access plus 1 hour"
ExpiresByType application/rdf+xml                   "access plus 1 hour"
ExpiresByType application/rss+xml                   "access plus 1 hour"

ExpiresByType application/json                      "access plus 0 seconds"
ExpiresByType application/ld+json                   "access plus 0 seconds"
ExpiresByType application/schema+json               "access plus 0 seconds"
ExpiresByType application/vnd.geo+json              "access plus 0 seconds"
ExpiresByType application/xml                       "access plus 0 seconds"
ExpiresByType text/xml                              "access plus 0 seconds"

Favicon (cannot be renamed!) and cursor images

ExpiresByType image/vnd.microsoft.icon              "access plus 1 week"
ExpiresByType image/x-icon                          "access plus 1 year"

HTML

ExpiresByType text/html                             "access plus 0 seconds"

JavaScript

ExpiresByType application/javascript                "access plus 1 year"
ExpiresByType application/x-javascript              "access plus 1 year"
ExpiresByType text/javascript                       "access plus 1 year"

Manifest files

ExpiresByType application/manifest+json             "access plus 1 week"
ExpiresByType application/x-web-app-manifest+json   "access plus 0 seconds"
ExpiresByType text/cache-manifest                   "access plus 0 seconds"

Media files

ExpiresByType audio/ogg                             "access plus 1 month"
ExpiresByType image/bmp                             "access plus 1 month"
ExpiresByType image/gif                             "access plus 1 month"
ExpiresByType image/jpeg                            "access plus 1 month"
ExpiresByType image/png                             "access plus 1 year"
ExpiresByType image/svg+xml                         "access plus 1 month"
ExpiresByType image/webp                            "access plus 1 month"
ExpiresByType video/mp4                             "access plus 1 month"
ExpiresByType video/ogg                             "access plus 1 month"
ExpiresByType video/webm                            "access plus 1 month"

Web fonts

# Embedded OpenType (EOT)
ExpiresByType application/vnd.ms-fontobject         "access plus 1 month"
ExpiresByType font/eot                              "access plus 1 month"

# OpenType
ExpiresByType font/opentype                         "access plus 1 month"

# TrueType
ExpiresByType application/x-font-ttf                "access plus 1 month"

# Web Open Font Format (WOFF) 1.0
ExpiresByType application/font-woff                 "access plus 1 month"
ExpiresByType application/x-font-woff               "access plus 1 month"
ExpiresByType font/woff                             "access plus 1 month"
# Web Open Font Format (WOFF) 2.0
ExpiresByType application/font-woff2                "access plus 1 month"

Other

ExpiresByType text/x-cross-domain-policy            "access plus 1 week"

AddType application/x-httpd-php .xml

#rederect
RewriteEngine On
RewriteCond %{HTTP_USER_AGENT} libwww-perl.*
RewriteRule .* ? [F,L]

HTID:2593276: DO NOT REMOVE OR MODIFY THIS LINE AND THE LINES BELOW

RewriteEngine on

DO NOT REMOVE OR MODIFY THIS LINE AND THE LINES ABOVE HTID:2593276:

RewriteCond %{HTTP_HOST} ^www.gamehup.tk [NC]
RewriteRule ^(.*)$ https://gamehup.tk/index.php$1 [L,R=301]

RewriteEngine on
RewriteCond %{HTTP_HOST} ^gamehup.000webhostapp.com [NC,OR]
RewriteCond %{HTTP_HOST} ^www.gamehup.000webhostapp.com [NC]
RewriteRule ^(.*)$ https://gamehup.tk/index.php [L,R=301,NC]

RewriteBase /
#only for the root directory
RewriteCond %{REQUEST_URI} ^/$
#if the uri is not already index.php
RewriteCond %{REQUEST_URI} !^/index.php [NC]
RewriteRule ^$ /index.php [R=301,L]


#12

@teodor can you check my htaccess file pls


#13

I refrain my answer. Try Header set Strict-Transport-Security "max-age=0;" instead.


#14

it retern thisThis site can’t be reached

gamhup.tk’s server DNS address could not be found.


#15

Domain gamhup.tk is no longer parked to Cloudflare.

Did you removed Cloudflare’s Name Servers from Freenom cPanel? :confused:


#16

nope i didnt remove them


#17

Please check your Freenom cPanel at gamhup.tk at Name Servers section.

Make sure gamhup.tk is configured with Cloudflare’s Name Servers.


#18

I check it but it didn’t work the site give me Error 500


#19

the name server is correct


#20

I have fixed the headers problem (check the .htaccess)


However the whois of gamehup.tk shows no Name Servers still :confused:

This problem is not related to 000webhost but to registrar not returning Name Servers on DNS lookup. Please contact Freenom and ask them about this problem. Tell them the DNS settings for gamehup.tk suddenly no longer propagate.