Using Cloudflare for SSL problem


#1

Hello everyone,

I’m a very noob in webserver and IT stuffs, so I hope to get some basic help here!
I’ve created a WordPress site using 000webhost, since it has https problem so I followed the tutorial of using Cloudflare service for a secured connection.

Every step was fine until the one where they say adding my domain to the control panel, I can’t seem to point my site to mysite.000webhostapp.com with the cname record I’ve created in Cloudflare, since it keeps appearing that my site isn’t “pointed” to, but “parked” to. I’ve made sure that the orange cloud in cloudflare is turned off, and I’ve changed my nameserver to theirs. So I don’t know what’s the problem here.

Anyone has the same issue?? Any help would be very appreciated. Thanks a lot!


#2

Where is the issue occurring? In CloudFlare or in your 000webhost account? :slight_smile:


#3

Hi Austin

Thanks for replying,
It happened when I try to add the domain in 000webhost, at this point of the tutorial:


#4

What error do you get in your account?


#5

I didn’t really get any error message, actually it said

web address updated

But I supposed after pointing my domain, it will be like this:


#6

Instead, the list didn’t change, and it appeared like below:

And https isn’t recognized in my page, so I supposed there’s something wrong…

Hope this can explain my problem!


#7

Your website seems be working fine from http, so you’ll just need to turn the clouds back on to get https. :wink:


#8

I did turn the clouds back on, but it didn’t get https, do I have to wait for sometime?


#9

Yes, it may take 24 hours to propagate globally. Also make sure that you have a valid SSL certificate. You can find that from the Cyrto tab in CloudFlare. :smile:


#10

I see, in Crypto tab it said

SSL certificate issuance may take up to 24 hours

so let’s wait! Thanks so much for your supporting!


#11

No problem! :blush: Please reach back if you still have the same problem. We’re here for you! :heart:


#12

Thank you :smiley:
I’ll come reporting after 24 hours :}


#13

Hi Austin,

I checked my website just now, both with Wordpress and site URL still haven’t got to https…
Turning the orange clouds on or off doesn’t change anything either. Can you tell me what should I do?


#14

If you could, can you please add me as a team member for your CloudFlare account? That way, I’ll be able to edit any settings that aren’t correctly set. My email is: accounts@myhexa.co :slight_smile:


#15

I just did! please check you email :slight_smile:


#16

Thanks :smile:. I just took a look at your CloudFlare account and it shows that your SSL certificate is still propagating. Did you change the SSL certificate option recently? :slight_smile:


#17

You mean the options of setting SSL to “flexible, full or off?”
I changed it yesterday and haven’t touched it again.
Btw do I have to do any setting in my Wordpress too?
Seems like I can’t access it either tho…


#18

You may have to wait a bit longer for SSL to propagate, as it’s currently not finished yet. Once that’s done, your WordPress site should work correctly, but if it doesn’t, you’ll want to install a CloudFlare flexible SSL plugin. Just search “CloudFlare SSL” in the plugins center of WordPress. :wink:


#19

Hi, dunno if you ever got this figured out, but it seems you were parking your domain instead of pointing it. Also, Cloudflare has been having some issues with their SSL infrastructure recently, so it sometimes takes a while to get a certificate.


#20

You will also need to change your wordpress URL to version with https in your general settings of your site.