"Your connection is not secure"


#1

I get the message “Your connection is not secure” when I try to access my website. I know it’s possible to bypass it by adding a security exception, but it might look suspicious to visitors. Is it possible to get rid of this problem?

My website is http://tehnoloogiaopetus.tk/ and I’m pointing it to tehnoloogiaopetus dot 000webhostapp dot com

Btw, I also asked freenom dot com (the place I got the the domain tehnoloogiaopetus dot tk) and they told me this:

“After looking into your issue, the error is related to the original URL: tehnoloogiaopetus.000webhostapp.com and not your domain name. We recommend that you contact 000webhost to get your issue resolved.”


#2

If you using WordPress https://en-gb.wordpress.org/plugins/wp-force-http/

Make sure this is correct http:// not https:// as well


#3

Thank you for reply.

I added and activated that plugin and changed the beginnings of URLs in General Settings to http://, but that doesn’t seem to resolve the issue.
In Mozilla Firefox, the website still uses https:// and when I change it to http:// it automatically changes back to https://
In Google Chrome, I can change the beginning of the URL to http:// and go to the login page without adding a security exception, but when I try to log in, it redirects to https://www.tehnoloogiaopetus.tk/?password-protected=login with the message “Your connection is not secure”


#4

I can’t tell at the minute because your site must be in maintenance mode etc but if you disable maintenance mode I think your site should load http:// forced no?


#5

What do you mean by maintenance mode? Do you mean the login page? The login page is supposed to be there - it’s a feature of the web page, not maintenance mode.
Or do you mean something else? If you do, how do I disable maintenance mode?

Btw, now it acts the same way in both Firefox & Chrome: [quote=“Marja, post:3, topic:46295”]
I can change the beginning of the URL to http:// and go to the login page without adding a security exception, but when I try to log in, it redirects to https://www.tehnoloogiaopetus.tk/?password-protected=login with the message “Your connection is not secure”
[/quote]


#6

Oh thought it was WP maintenance mode.


#7

Best regard

I have the same problem with my web page, this is targeted to Freenom.com, in Google Chrome indicates that the conection isn’t secure because *000webhost could not prove that the web is Romantica Baladas del Amor, this occurs both in the url: romanticabaladasdelamor.tk, www, http and in https; I searched in the settings of 000webhost but i can’t finded anything solution.


#8

I also am experiencing this problem. Anyone figured out how to fix / correct it?


#9

redirecting from https to http can be achieved by copying and pasting the 3 code lines below to your .htaccess file

Redirect HTTPS to HTTP

RewriteCond %{HTTP:X-Forwarded-Proto} =https
RewriteRule ^(.*)$ http://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

this has to redirect https://www.tehnoloogiaopetus.tk
http://www.tehnoloogiaopetus.tk

source https://www.siteground.com/kb/redirect-from-https-to-http/


#10

As infinity suggested

change these url to domain name with “http”

But remember dont use “https”