Cannot browse my web site


I am new, I signed up and created a free web hosting. I also uploaded my index.html to the server via file manager. But I can not browse my web site:
I also tried the link with extension /index.html but no success.

What is the problem, what do you think?



Please clear your browser’s cache and again :wink:


It didnt help. I also tried from an other computer and an other network. I still cannot browse. Did you check if you can browse the site?


It loads fine as above


Interesting… I cannot browse the link. However, when I use VPN I can browse. This shows that my country blocks the link? I have been in Turkey currently.


Maybe it has to be with your ISP.
Try flushing your DNS.


I tried flushing the DNS. Still same. Nothing helped. Do you have any address which I can try to browse? I want to see if I can browse an other site under domain.


Try and and reply with the results.


I can not browse neither. However I can browse with VPN.

With, I can browse and get the following text:
You are seeing this because you are browsing this website through https connection. That means the SSL certificate is working.Did you know you can get premium hosting for the price of nothing?! Click on the banner below for more info!


Sorry but your ISP is blocking urls, those 2 urls I gave are linked to the same app.


@zaferaydin Were you able to browse previously, If yes then, it’s an temporary issue because of clouldflare security check, and wiil be solved automatically.

Meanwhile use VPN, till the original issue is solved.

Also try this tutorial, see if this helps you.


Hello @akhilkumar332, My site has never been browsed. For me, it is not working from the beginning. Whatismore, I followed the instructions in the tutorial from your post but still I can not browse my site. I think ISP in Turkey is blocking urls as ckhawand said.

Thank you ckhawand . I guess we proved that ISP is blocking webhostapp urls as you said.

Now, if I buy a domain name and redirect it to my free webhostapp site, will i be able to browse? What do you think?


Yes, that is what you did when visiting those two URLs.
The would be masked, and you will be able to access it without problems!
I recommend buying a domain from Hostinger, you will get the branding removed for the cheapest prices!

I posted a wrong link, try browsing the new link now, the previous one was a link to upgrade, sorry for that :)


@zaferaydin Contact your ISP, and ask them to unblock * url’s,

Also the other day, i saw similar issue and the user is from turkey too.
I believe this is because of cloudflare. And will be solved automatically.
Note:- There is no fixed time scale for this.

Meanwhile also contact your ISP as said above.


@zaferaydin Aynı sorun bende de var a bağlanamıyorum önceden bağlanabiliyordum engellemiş olabilirler siteyi umarım cloudflare ile ilgilidir de çözerler yakında

İ have same problem too i cant accsess my site from turkey hope it will be fixed soon


Hello @Heyo and everyone. I contacted my ISP provider, they replied me that there is no blocking or limiting to *** web site. They said “…you can get help from the site you have been facing problems…” I was about to be sure that they were blocking the domain. Now I got confused.


Have you tried updating Google DNS in your Adapter IPv4 settings??

If not, plz try and see this helps you.


I have tried already. Now I tried again. Still same problem…


Can you screenshot your IPV4 settings from your active connection please?


you can see the screenshot on the link below:
I think there is no problem with my ip settings.