Can't Reach Upload Files

Why is it that I can open my website, I can open File Manager but for Uplaod Files, I get the message “Can’t reach this page.”

I’m thinking maybe there is some issue on their end. I’m having the same issue. Also cant FTP into my site. Been having this issue since yesterday.

Thanks for mentioning your experience. But I wonder when they will addrees this issue. We can’t afford to spend hours just trying to get to our files to work on our website.

Honestly this has been 3+ days, come on 000webhost, you’ve been fine until now

I need screenshots of FTP connection logs to pass to developers,

If there are nodes down and known of there is not much to do but wait out the traffic.

Just checked currently there are two nodes down, they have had issues the past day or two, DevOps are working to improve FTP constantly


I have been using 000webhost as a repo and suddenly I am no longer able to FTP into my website. I have tried multiple computers and networks. The credentials I am inputting are definitely correct. I have tried multiple different FTP clients. I have also tried the “File Manager” on and when I click “Upload Files” it loads for a second and then I get to a screen saying “Hmm. We’re having trouble finding that site.”
Thanks for any help, I definitely need to be able to FTP into the site in order to utilize it,.

As above see the “troubleshooter” and regarding the nodes out of action we will have to wait for that.