Change Password Link not working

I clicked forgot my password, 000webhost sent me an e-mail with a link to set up a new password but all that the link does is get me back to the log-in page.

Try requesting another one?

I did (after I posted my problem), - same result.

I think you’ve solved this so I’ll mark as solved unless you come back with more information.

No, this issue is not resolved.
the URL is
and when I Log-In it tells me my password is wrong so I click on “Forgot Password?”, enter my e-mail (which is the same as the one I entered when trying to Log-In) it tells me an e-mail was sent to me to with a password reset link. I receive this e-mail, click on the link provided and it takes me back to the Log-In page - right back to where I started! The Link provided is, in my opinion, a wrong link.

Any screenshots or further info?

The problem is straight forward: the link provided by webhost to reset my password is wrong - it doesn’t do the job - it simply brings me back to the log-in page. Here is the screen shot although I don’t see how that can help.

Thanks I’ll report this to developers and hopefully have some news tonight or tomorrow.

It seems to have been solved…