Clicked pages loading as mywebsite.000webhostapp.com/example.html and not my domain/example.html


#8

I can’t see any nameservers listed.

Can you screenshot your registrar domain page showing the nameservers correctly?


#9


#10

How can I pull up this to view? I’m interested to see what the cname tab says. On 000webhost it says my site is linked by the cname

Should I try unlinking then relinking my domain on 000webhost?


#11




NSs haven’t fully propagated yet.


#12

Thank you so much for this!

Seriously the best support/community forum I’ve ever used lol.


#13

No problem.
We are here to help, and we are doing our best to keep our customers happy!
Each customer counts! :slight_smile:


#15

Should I check with 1and1 about why the nameservers still haven’t propagated? It’s been well over 48 hours since I did everything


#16

I just went ahead and called…1and1 said everything is fine on their end and that with the hosting it’s not getting something for the A record or it’s showing there’s no IP address?? Idk I didn’t really follow what he was trying to say. Now it’s becoming stuff I don’t understand lol.

Should I try unlinking my domain in the cpanel and relink it?


#17

There should be no A records whatsoever, we don’t use them. Can you try setting up your domain using the CNAME method?


#18

There no way for me to edit the cname on 1and1. It only lets me edit the nameservers and you can edit the cname for a subdomain, that’s it

When I first tried to link my domain it wouldn’t link. It kept saying I needed to update the cname and I couldn’t do it I just did the nameservers and hoped maybe it would calibrate something with the cname. So instead of linking the domain as a pointed address, I parked it. Then it finally let me link my domain and on my backend of 000webhost it says it’s linked by the cname.


#19

If you can only edit nameservers, try using Cloudflare so that you have a full DNS zone. The tutorial below will help.


#20

Thank you! Is there an MX records I need to add? It says there’s no MX record


#21

You don’t have to, it just tells you that.


#22

Okay so it’s working now (it says changes can take up to 48 hours but this was almost like instant)

So I navigate to marisa-lander.com and the website is up, yay!

Now I’m back to my original problem but worse!! Lol. When I click a link it’s navigating to mysite.000webhostapp.com/blahblah and showing a database error. I try manually navigating to mydomain.com/blahblah and it shows the same error


#23

The wordpress site is linked to the domain

Should I maybe delete and reinstall WordPress?


#24

Your can try that. :slight_smile:


#25

This is what I’m getting when attempting to access /wp-admin from the domain name


#26

Install it again.
After installing, and add this piece of code in your .htaccess file ,

Now Login in to your wordpress admin panel.
Then go to “Settings” >> “General” and change both site and wordpress url to your domain name.


#27

Yay everything is working now! Thank you everyone so so much for all of the help


#28