CloudFlare and Wordpress - SSL problem



I’ve been trying to get cloudflare to work for the tree days now with now luck. I own the domain . I’ve created a website at 000webhost, then setup at Cloudflare, with the settings given on this forum. and www --> my 000webhostapp address with the orange clouds turned on (it does not allow me to insert @). I’ve changed the nameservers at my domain host to what cloudflare gave me. Once Cloudflare showed the site was up, I pointed to my 000webhostapp url via 000webhost control panel. It successfully added both domains (with and without wwww and changed the SSL type to flexible and Cloudflare shows it’s active.

I can connect to my site trough http:// but https in all browsers (IE, Chrome, Firefox) returns
"This site can’t provide a secure connection uses an unsupported protocol.

For past tree days I am reading all related threads here and on CloudFlare but cannot fix this. In CloudFlare panel under Cripto, status of the certificate states “Initializing Certificate”. Does that mean that SSL is still not active?

Also, in Wordpress under settings when I choose Cloudflare, message “forbidden” shows but it does display Cloudflare options trough the panel.

Can someone help me resolve this so I can use my site with https?

Thanks in advance :slight_smile:


hi @AninaO
You have to change your wordpress url from http to https in your wordpress setting


I already tried that and same thing happens:


Can you screenshot your cloudflare SSL tab


Owerview tab:

DNS tab

Crypto tab

And Cloudflare in Wordpress:


Alright when the certificate status turns to Green then you can begin using it.


I tried this and I was totally blocked out of my wordpress website until I changed my nameservers to the default 000webhost nameservers. And I also received 2 messages

  1. Time and date problem and the security certificate could not be authenticated and
  2. Too many redirects


My certificate status is green but my website is still not secure


Screenshot your cloudflare dns tab and have you properly pointed your domain to 000webhost?



when i edit address to https and not http
there are too many redirects and the website wont load



Are you using any WordPress SSL plugin?