cPanel Sleep time dos not show in Firefox, works in Edge


#1

Hello!
When I try to show temporary sleep time in Firefox (both 47.0.2 and 56.0.2) - there is just placeholder left. Same problem appears on Notification Line. Please see the pictures at the end of this post.

Everything works properly when accessed from Edge.

When I looked into Network (using Developer tab - F12) I found strange difference in API calls:

Firefox (not working) calls: https://rest.000webhost.com/v1/users/me/website-pauses
Which returns:

{"result":[],"error":[]}

Edge (which works properly) calls: https://rest.000webhost.com/v1/apps/pil/app-pause
Which returns:

{"result":{"from":"18:00:00","to":"19:00:00","enabled":1,"allow":1,"next_allow":"2017-11-08 19:00:00"},"error":[]}

My Website is https://pil.000webhostapp.com/

Best regards
–Henryk Paluch

Attached screenshots from Firefox (not working):



#2

@ckhawand can you do your thing and see if you can set a time?


#3

I am also getting this in Firefox, but it works OK in Google Chrome. So I set the sleep time using Chrome, then when I viewed the settings in Firefox it displays -

“You only allowed to change website sleeping times once a day. You will be able to change sleeping time after NaN-0NaN-0NaN 0NaN:0NaN”

The underlying code for this is -

            <small ng-show="!settings.appPauseAllowUpdate">
                {{'You only allowed to change website sleeping times once a day' | translate }}.
                {{'You will be able to change sleeping time after ' | translate }} {{settings.appPauseNextAllowUpdate}}
            </small>

I will leave it to someone more knowledgeable to determine how to fix this!


#4

@mantas.daraciunas

:1234:


#5

Do you still need me?


#6

If you have Firefox yeah sure not bad to try and replicate the issue.


#7

@Infinity

I checked it. Firefox shows bad results (NaN)

Your website will be sleeping for 1 hour from NaN:00 to NaN:00 (+1) every day your local time (GMT +5.5)


#8

Dear @hpaluch,

Thank you for spotting this issue and letting us now. We will work on an update to solve this issue! Thank you once again!