Database error Expression manquante. (near "ON" at position 25)


php version 5.4.12

and no scripts installed


So no plugins to work alongside WordPress?

Head to

And see the plugins are all installed and updated to be working correctly.

The same for any custom themes, ensure the right theme is selected and working correctly.

Else screenshot and point out to me what is missing / different from the local install.


Good morning mate yesterday I could not send this message because the rights of use of topic.

normally the display of the site will show me the same display on local with the plugin opal hotel booking and different exhibitions … what I see is the theme at the time of its installation !!
which is wrong!!!

so i head but an error says “Sorry, you do not have permission to access this page.”


because of forbidden access to wp-admin from wp-admin
I tried to check wp-options in the database siteurl and home but everything is right…

after that i was rename the plugins folder but no result… and then rename the installed theme and the result for the wp-admin is still forbedden access wherever result for link site is in the screenshot below


I’ve not changed a thing


This typically means the database was having issues >


I believe you should be able to login now.


waw! always I say I have the bad luck in the world!!

do I have to do something now?

so how long do I have to wait to get my website online without problems please ?


Database should be fine right now.


I can login but the site is not like the local version !!
it’s no longer the homepage I’ve make it


this is my homepage … i 'm sure there is a problem with database


Export the local database and upload to originalfiles?


yes i did it last time you can find mayasseen.sql in my file manager


Could be database related, since you’ve got everything set to work on localhost, all the values are wrong for 000webhost.

I tried doing a search and replace for localhost and putting your URL instead, imported it but it doesn’t seem to have much difference.

If you open the .sql file locally and CTRL+F localhost you’ll see what I mean.


So I’ve done a lot of mucking about and it seems to be getting there.

I’ve imported my changes into database and uploaded the changed .sql file into public_html for you to skim over if you want.

I’ll have another look later but swamped currently.
It is changing the content that is time consuming

That last one I’m not sure what to replace with?




so i continue replaced localhost with siteurl ?


mayasseen (1) .sql is now uploded in file manager

i was replace all “localhost” with""


Just take a scan through the file and anything that links it to localhost or c:/ or xampp needs to be changed :frowning:


ok i just changed and uploded mayasseen (1).sql in my file manager

what is the rigth way to import it in database?


so are you still with me mate?