Domain doesn't work with "www" prefix


#1

I can access naked domain but when I add www in front (like www.domain.com) it loads a blank page.

Domain under question is

touchmark.tk

I use Cloudflare for DNS.

Can anyone suggest a solution?


#2

Hi @prorocks2013!

The problem is related to Wordpress. After what plug-in have you started to experience this problem?


#3

Log in to you cloudflare account, then go to DNS section,
and Add @ record pointing towards your *.000webhostapp.com url.


#4

I have not installed any new plug-in for a long time!

How do I diagnose this problem?


#5

I have done that long time ago…two cname records are there
one is @ i.e. naked domain
another is www
both point to my *.000webhostapp.com
They are setup in Cpanel successfully


#6

The request is sent with status code 200, this means there is no DNS issue:


Wordpress refuses to render content, however I have no idea why :confused:.

Let me check a little bit the database…


@prorocks2013 UPDATE: I have fixed the issue. It is caused by one of these plugins.

Currently they are removed. Please re-install them and check which one is causing the problem, one by one. Press CTRL+F5 to fully refresh the webpage for testing. Also, I have set the default Wordpress address to https://www.touchmark.tk


#7

Well they’ve been with my site for a long time. I do not know how it happened just today.


#8

Without them it works. Probably some interference occurred and this is why it happened today.

But as I said already, I don’t know which one of them is causing the actual issue. This is why I am asking you to check them one by one. I mean, I removed them, but I can’t add them back now… However you have access to WP admin, and you can add and check them from there…

Note that WP Static Cache caches the requests. I suggest you to test the plugins without it.


#9

Thank you. I see you haven’t deleted them. So I have to just rename those folders and reload my site?


#10

uhm… I am not sure honestly…

Please rename them (remove the dashes) and then go to WP admin and check if they are still there…


#11

Well. Thank you again. You were right about Wordpress issue. I am happy that I took help of someone exprienced.

The images are not loading actually. In the backend (WP Dashboard). Front end is okay. Any suggestions?


#12

#13

What are your WP Admin credentials? I think after all I will check for you… :wink:


#15

:confused: :confused: :confused:


#16

Oops sorry about that. I will deactivate that plugin. Extra layer of security youknow

UPDATE: Deactivated the plugin. reply when you successfully login


#17

Thanks!

I have logged in…


#18

Do you see the images? You notice that sidebar? Options miss logos…and they just remain thumbnails


#19

Yes, they don’t load indeed…

The sources from which they attempt to load return Error 403 - Forbidden

I’ll try to find a way to bypass this…


#20

What’s more awkward is that in browser the resources are loading perfectly.

Do you have extra security set up in Cloudflare?


#21

Shall I try to pause the Cloudflare protection for a while?