Domain not working - keeps redirecting to old domain



I was originally using a domain temporarily on my site ( however I bought a site appropriate domain today

I deleted the domain off the webhosting by unlinking it then deleting it. Pointed the new domain name servers to the appropriate ones for the site and parked the domain through the control panel.

Took about 5 hours for the 000webhost panel to pick up on the new name servers and I linked the site to the domain.

however, when trying to access, the site resolves the host in the status bar on google chrome, but then redirects the page to, which then fails to connect because the domain is no longer parked on my hosting.

Strangely enough, the sub-domain when given with free hosing…in my case ALSO redirects to and I have no access to my web page. Tried on my mobile browser, desktop and a friend also tried.

Any advice on the matter as it seems something hasnt gone through correctly on the hosting side servers causing a redirect that shouldnt be there.




I fixed the issue for you, however you have a rule that redirects to HTTPS automatically, which will cause a hostname mismatch for anyone who visits the site. You need to use the tutorial below to setup using Cloudflare so that HTTPS and SSL will work properly, then everything will work for you.