Email forwarder to gmail problem

I am having issues with the email forwarding service. I am a free hosting client.
I set the MX record to since the the receiving email is in gmail.
Then, going to Manage Email Forwarders and creating a new email forwarder, I get a notification on top: Domain MX record will be changed to before I even set From and Forward to both emails.
Ignoring the notification, the MX record automatically sets back to
And as a result, no email is received when sending test email to the forwarder.
What I do wrong with this setting?
My 000webhostAPP name is unblamable-crowns
I am not sure if I can post the domain.
The domain is parked, the nameservers are NS01.000WEBHOST.COM and NS02.000WEBHOST.COM

000webhost forwarders are pretty unreliable.

If you are setting MX record to use Google then you cannot use forwarders anyway.

See using GSuite/Zoho or Migadu

Many thanks for the solution.
Unfortunately, my domain is free by Freenom and is one of those Migadu doesn’t provide service to.
I guess I will have to buy a domain anyway. Thanks .

1 Like

This topic was automatically closed after 47 hours. New replies are no longer allowed.