Error 500 shown in new language page


#22

I’ve tried to control page addressing in the meantime. But I could not find a clear statement on the Internet how a page is addressed to Thailand.
Meanwhile, I have done a Chinese laqnguage in - without problems. But China also has a clear address that can be found on the Internet.
Can the error lie here?


#23

That was it? No more answer?


#24

Hi @Buno!

These 500-errors can only be remedied by repairs to the web server software. There is no problem on the client side.

Partly wrong. In certain circumstances it can mean PHP errors as well.

Please go to 000webhost cPanel > Settings > General > Show errors > On. Reply after doing so.


#25

Hello,
it was already on “ON”


#26

Toggle it on/off, maybe it was deleted from .htaccess


#27

Also, please lower your PHP to 5.6: 000webhost cPanel > Settings > General > Change PHP version > 5.6


#28

Done! PHP is now 5.6 and I switched it OFF and ON


#29

What system have you used to build your website? (beside Zyro)


#30

The shop is made by Zent Cart


#31

Please go to 000webhost cPanel > Settings > General > Fix files permissions and try again…


#32

done, but doesn’t works. It shows me the page 500 same before


#33

Contact the developer of the language pack to sort the issues.

Do you have a link to the Thai language pack to download and I’ll test it on my Zencart?


#34

Contact the developer of the language pack to sort the issues.

Yes, that’d be the best idea. I suspect some interference between Thai language and the PHP scripts, however I am not sure. It’s odd that it doesn’t show any errors though, but inside PHP you can set up to show no errors, and this option is more plausible.

In any case, 000webhost has nothing to do with this. This is a software related problem…


#35

Yes, you can be right. There is no original Thai language pack. Instead, I changed the Zen language pack “Chinese-Simple” to Thai. Now I’ve discovered that Chrome shows an Error 500 message, Firefox has a different hint. So I looked at the source code and found that the HTML builder continues to accept the Chinese side and the Thaisite he wants to build after that, which does not work.
So now it’s about making the HTML builder clear that he has a Thaisite to build. But I do not know how to do that. Do you have a tip for me?


#36

So now it’s about making the HTML builder clear that he has a Thaisite to build.

I don’t know what HTML builder are you using.


#37

?? I don’t know, too. The HTML is build from Zen Cart and it’s doing “in the back”. I have here the normal install program from Zen Cart and there I cannot see which of the files have to do with HTML. So I hoped you know that.


#38

It’s purely seems to be language script issue that you modified(“Chinese-Simple” to Thai), i would suggest you to go to related forum and check for solution.
Or use original Thai language Pack.


#39

If Zen had a Thai language pack, I would not make my own !!! :smiling_imp:


#40

@Buno Try this link:-

Remove previous thai modified files and try this.
This should help you.


#41

Thanks for the hint, but the Thai package is Zen 1.1 with windows-874 and I use Zen 1.5.5e with utf8.
I have found under Oscommerce a full Thai language pack and copied to the server. Zen and Oscommerce is almost identical, but it also does not work.
It is not synonymous to the translated sides or the installations! It’s up to the HTML builder. And I have no influence on it and do not know how to change anything. I can see only that itäs wrong if I open the language site as source code. There is a lot for web developers, but I know not there. So I hoped that you can show me where and how I describe these HTML pages.