Fatal error: Allowed memory size of 67108864 bytes exhausted


I have 3 wordpress site and they had the usual 404error page. But since yesterday one a my website have the message “Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 8192 bytes) in /home/axxxxxxx/public_html/wp-admin/includes/theme.php on line 1”

now it’s theme.php but it always change (yesterday it was deprecated.php with random line number).
I had a visit from the white house too (i saw this on google analytics “executive office of the president”)… i think there is a threat in my website…

Now i can login and acces in the admin panel for the other 2 website but this one has always the fatal error…

anyone has an idea?

thanks in advance


You can follow rules forum and use “Search forum” with words “Allowed memory size” before you asking.
You are going to get more of one results, e.g.

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 7680

I having the same issue since the DDoS message disappeared…Could it be something relationed with 000webhost’s problems again?
I didn’t change anything on my site, and the adding space line in wp-config didn’t work at all…
anyone knows what could it be?
Thanks a lot.

Have you tried replacing theme.php in the error message? Back it up first though.

Thanks for your reply!
You mean replacing theme.php for a new one?
I downloaded the last version of WP (which I already had on my site), and took the theme.php from there and replaced the one I had, and nothing changed.

I’m getting the error on theme.php, but the error line number is changing constantly, and so does the amount of bytes that it’s trying to alocate, does that mean something?


Where is the error message? After you try to login? What about changing the theme back to twentyten using phpmyadmin - http://wordpress.shadowlantern.com/change-wordpress-theme-in-phpmyadmin/
You could then delete and re install the theme you were using, maybe it got corrupted at some point

I’ve tried what you said, and actually I could log in with the default theme, but there were errors in different places at the dashboard (incoming links, last post, and so on). And everytime I try to reinstall the older theme, the error comes up again and I can’t do anything.
I really don’t know what could it be, but it seems that something is overloaded.
The strange thing is that everything was fine before the DDoS attack.

What version of WP do you have? Upload the right version of wp-admin folder overwriting the old one.
Might be an idea to upload all new folders and files except wp-content; the way you would if updating to a new version of WP manually.
http://codex.wordpress.org/Updating_WordPress scroll down to Manual Update

just for information i’ve changed the memory limit to 96 and it works now (thanks modo :)).
But i am going to change the server, there are still problems

Sorry I didn’t post for a while, I was trying to fix this by myself. Now the thing is that wordpress started to work fine two days ago, and now when I tried to publish a new post, things started to go wrong again.
But this time is worse, now I can’t even enter to the dashboard by changing to the wordpress default theme.
I think maybe it’s time for me to move to another server too :frowning:

OMG Nooobs!

Same thing happened to me. Before 000webhost disabled WordPress sites my site used to use 35MB. Now it uses 63MB!! I don’t know why but even after re-installing it still uses that amount.

On my local copy wordpress only uses 40MB (with XDebug!) so I don’t know what happened.

This is what I did that fixed the problem:

  1. Create A separate user for posting pages, etc. Don’t use your admin or an administrator account to post. This should save some RAM.

  2. Disable all your plugins (PHPMyAdmin):

UPDATE wp_options SET option_value = ‘a:0:{}’ WHERE option_name = ‘active_plugins’;

  1. Only re-enable the plugins that are necessary!

  2. Set wordpress memmory limit to 64MB in wp-config file:

define(‘WP_MEMORY_LIMIT’, ‘64M’);

  1. If you use paid hosting you can increase your memory LIMIT


memory_limit = 256M ; Maximum amount of memory a script may consume (256MB)

.htaccess file

php_value memory_limit 256M ; Change the 256M to your needs

wp-config.php file

define(‘WP_MEMORY_LIMIT’, ‘256M’);

Hope this helps someone

I don’t know why PHP is all of a sudden using more memmory. 000webhost is the best free service out there? So where are you gonna go? :stuck_out_tongue:

I’m sure they will stop frustrating wordpress users after some time. Be patient!

Who can help me again with this problem? I have few domains here in 000webhost. I had same problem before with my first domain and I fixed it myself using your tips. Well, now same problem my other domain and I can’t fixed it. Not so good memory myself either:(

I tried to push define(’WP_MEMORY_LIMIT’, ‘128M’); to wp-config.php file, but no help. What I do wrong this time? I think so, that this was the right solution…

And problem coming always if I try to install wordpress SEO plugin. I can upload it for Filezilla, but when I try to install plugin: “Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 7680 bytes) in /home/a6379962/public_html/wp-admin/menu.php on line 244”

your best bet is to remove all plugin and only enable the one you are really need and please do not use any plugin relate to cache since most of the attack recently are geared toward cache

Please post the exact plugins you have installed. WP SEO does not use that much RAM. It has to be a big plugin. Either one that works with files or one that works with Images:

[*]Look for following plugins: Gallery Plugin, Security Plugin (Better WordPress Security, WordFence, Bullet Proof, etc)

[*]Make sure cache does not pre-load but only create caches on page access.

[*]If you are using PAID HOSTING then 256MB Should be enough. Maybe your site has been infected? See: http://codex.wordpress.org/FAQ_My_site_was_hacked and [URL=“http://sitecheck.sucuri.net/results/mast3rpee.tk”]http://sitecheck.sucuri.net/results/mast3rpee.tk

I have tried sucuri and it detected http://sucuri.net/malware/php-error-fatal-error.:frowning:

What should I do remove this error? Thanks.

This works
Put this line

php_value memory_limit 128M

at the very top of your .htaccess file

Long answer - http://www.free-installations.info/threads/fatal-error-allowed-memory-size-of-67108864-bytes-exhausted.5132

Thats not a virus. forget about that. You have to disable plugins then scan again.

This is another great one. Looks like many have similar ways to over come that and its good that you solved it.

Hi everyone!

I’m facing this problem from a long time too…
But it’s more weird with me. It’s showing this error for many plugins that I’ve installed in my wordpress. So for checking purpose, I simple went in and removed those plugins.
But it never stopped. It gave same problem for another plugin and I removed that one too and then again for another plugin.
So I guess there is something else that’s creating this problem. May be something wrong from the server side.

But few days ago, I didn’t do anything but the site just resumed.
And now same problem again.

It’s so irritating.