Ftp error (operation failed)

I am attempting to edit my files over FTP, yet again. I get the following error in PHP:

Warning : fopen(ftp://...@files.000webhost.com/public_html/index.php): failed to open stream: operation failed

Nothing has changed since last time. I just tried repairing the site, even toggling FTP on and off.

My site is sourceshopper. Please help me with this. PHP is not at fault, either permissions are incorrect or I mistakenly messed something up.

FTP is working fine.

Maybe try again :slight_smile:

@Infinity Nope. Problem still persists. I am connecting via PHP FTP using port 21 Is this correct?

I refuse to use the built in 000webhost FTP. It disconnects frequently and navbar resizes once clicking on a file on a smaller window, making me click on a different file.

Not sure why you are still facing issues, just tried File Manager and FTP Client FileZilla and no issues on my end over my local connection and using Windscribe VPN.

Maybe give a proxy/VPN a go

Failing that try restarting your router to gain a hopefully new dynamic IP address.

Do I need SFTP? Port 22? Even this online FTP does not work (I believe it is built with PHP as well) https://onlineftp.ch/

I’m confused. PHP never does this, not even on my own FTP server. Is the address files.000webhost.com/public_html/ for the public_html folder? Or do I need the /ssd2/ thing? (project root on your server)

Working fine here.

Hostname: files.000webhost.com
Username: sourceshopper
Password: pick a new one please
Port: 21 or blank

This topic was automatically closed after 46 hours. New replies are no longer allowed.