FTP: Login authentication failed

I am new to 000webhost and I have used other webhosting site but my FPT details seem to be not working, it all is green but I get an error:
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 17 of 50 allowed.
Response: 220-Local time is now 10:31. Server port: 21.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER a2490797
Response: 331 User a2490797 OK. Password required
Command: PASS ******
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

My Password is 100% right. I’ve even tried changing it, have you go any solutions?

It says the password is wrong, how are you changing it? The account password is different to the ftp password.
Click View FTP Details in CPanel and then **Change account password **

That’s what I have been doing.

Are you using a domain name for the host? Has it fully propagated? Try using the IP instead.

I tried using the server that I am on. That works fine…

Best to make a backup of that site in your profile, it’ll get suspended as soon as it gets reviewed; IP boards aren’t allowed.

Why, I paid for the IPBoard ages ago, been looking for a web host. I will just incase though. Thanks for the info

It’s because they don’t have time to check licenses and it’s just one more way for servers to get abused - imagine all those 10,000’s of nulled VBulletin boards suddenly turning up, wouldn’t be long before all their servers were blacklisted.

This is what will catch it, the manual review - http://www.000webhost.com/admin-review