Help! Forms on my site displaying error after clicking submit: https://webapplicationtrainingga.000webhost.com


#1

I usually get error on my site when I fill the from on the site and hit the submit button. This error was not showing on my xampp and I have also uploaded this script on another server few months ago and it works fine. Please what could the problem be and how can I get this resolved as soon as possible.

Please what could the problem be. Is it a php version error or what exactly could be the problem

Here is the url to the site again

https://webapplicationtrainingga.000webhostapp.com


#2

Please paste lines 40 -> 50 of your PHP code


#3
if ((isset($_POST["MM_insert"])) && ($_POST["MM_insert"] == "form1")) {
  $insertSQL = sprintf("INSERT INTO paidreg (SN, Name, Email, Telephone, Address, Username, Password) VALUES (%s, %s, %s, %s, %s, %s, %s)",
                       GetSQLValueString($_POST['SN'], "int"),
                       GetSQLValueString($_POST['Name'], "text"),
                       GetSQLValueString($_POST['Email'], "text"),
                       GetSQLValueString($_POST['Telephone'], "text"),
                       GetSQLValueString($_POST['Address'], "text"),
                       GetSQLValueString($_POST['Username'], "text"),
                       GetSQLValueString($_POST['Password'], "text"));

  mysql_select_db($database_webapp, $webapp);

#4

So, $_POST[‘SN’], $_POST[‘Username’], $_POST[‘Password’], are not set :slight_smile:


#5

But even with that it works fine in my xampp and also on other servers.

What do you think I should do to get this error off my site. Was not thinking that could be the cause of the error.

If I may ask, is there any particular syntax or structure that is accepted on this platform?


#6

The GetValue method in the PHP code should take care of what you sent


#7

I have checked. I get the data sent from the form in my database table but the error on the frontpage keeps displaying


#8

When I fill in the form on this page I get an error instead of a redirect to a registration successful page.

I run this script on xampp and it works very well and I also uploaded to another server, it works very fine.

Please what do I do to resolve this problem.

Thanks


#9

Did you take care of case sensitiveness?
I guess Username is not username in UNIX systems :slight_smile:


#10

I have checked through the case sensitivity issues. That is not the case. I used the same case with both in UNIX and LINUX

I do not think that is the problem.

Please help check further so that I can get this resolved as soon as possible.

Thanks


#11

Doesn’t appear to be anything on our side of things.


#12

I will check through the codes one more time. Probably a reprogramming might be my last resort


#13

I have checked through but can’t place anything from my end either.


#14

I think the problem must be from your end. I just checked this other form in the same application and it is giving the same error.

Here is the link to the form https://webapplicationtrainingga.000webhost.com/freedownload

There is another form on this link when filled it gives the same error as the initial one i sent earlier


#15

I think the problem must be from your end. I just checked this other form in the same application and it is giving the same error.

Here is the link to the form https://webapplicationtrainingga.000webhost.com/freedownload

Check this form too it gives the same error


#16

Tried the fix option from general settings on 000webhost.com?


#17

Please how do I do that?


#18

I saw the repair option under the general settings and I tried it. The error is still there