Help Please With Fatal error: Allowed memory size of 67108864 bytes exhausted Error


#1

I have a wordpress blog I just installed on this domain www.help4yourhair.com and I am in the process of setting everything up (installing plugins, etc.)

I am constantly getting this **Fatal error: Allowed memory size of 67108864 bytes exhausted **error and it is driving me crazy. I am assuming that the free server is only going to give you 32 bit so I am not going to even waste time with the old WP-Config trick to force make it 64-bits (which doesn’t even work anymore anyway.)

I figured it was a caching problem so I installed W3 Total Cache plugin and am using Cloudflare as a CDN to alleviate this but I still get this error all over my admin panel. I read somewhere on the web that it was possibly too many plugins so I deleted all but three and still get the error!

Does anyone have any advice on how to alleviate this problem?


#2

You can use “Search forum” with words “Allowed memory size”.
You are going to get more of one results.


#3

Thank you! I did what you suggested and found the solution.


#4

Sorry just to be clear, using search forum with words “Allowed memory size” did the trick for you?


#5

Yes it did. I found an article that helped me with the error.


#6

D3iti I hate you! Why won’t you answer questions! :mad:

If you have time to make all these posts why don’t you make sure they actually have some information? :stuck_out_tongue:

Look at the last 100 posts you have made! (Not 1 solution!)

http://www.000webhost.com/forum/search.php?searchid=2137838

YOU SHOULD BE BANNED!!!


Same thing happened to me. Before 000webhost disabled WordPress sites my site used to use 35MB. Now it uses 63MB!! I don’t know why but even after re-installing it still uses that amount.

On my local copy wordpress only uses 40MB (with XDebug!) so I don’t know what happened.

This is what I did that fixed the problem:

  1. Create A separate user for posting pages, etc. Don’t use your admin or an administrator account to post. This should save some RAM.

  2. Disable all your plugins (PHPMyAdmin):

UPDATE wp_options SET option_value = ‘a:0:{}’ WHERE option_name = ‘active_plugins’;

  1. Only re-enable the plugins that are necessary!

  2. Set wordpress memmory limit to 64MB in wp-config file:

define(‘WP_MEMORY_LIMIT’, ‘64M’);


  1. If you use paid hosting you can increase your memory LIMIT

php.ini

memory_limit = 256M ; Maximum amount of memory a script may consume (256MB)

.htaccess file

php_value memory_limit 256M ; Change the 256M to your needs

wp-config.php file

define(‘WP_MEMORY_LIMIT’, ‘256M’);

Hope this helps someone


#7

If you use free hosting

[LIST]
[*]Do not use w3 total cache

[*]Use wp super cache!!! It uses less ram!!!

[*]Do not install more than 10 plugins!!!

[*]Do not install more than 2 plugins that are more than 1mb in size
[/LIST]

Thank you :slight_smile:


#8

Oh with this error You can use “Search forum” with words “Allowed memory size”.


#9

If you have time to make such long posts then you have time to read the rules :stuck_out_tongue:
http://www.000webhost.com/forum/customer-assistance/4-forum-rules.html

Posting Rules

#1. Before posting ANY topic, please search forums for answers to your questions. It’s possible that all your questions were answered already.


#10

Shock please do me one favor and do a search for:

Fatal error: Allowed memory size of 67108864 bytes exhausted Error

OR

Allowed memory

Then tell me which page has a solution so I can feel reeeeeelly stupid. :confused:

I reallly like feeling stupid :stuck_out_tongue:

(by the way exclude all of my solutions obviously)


#11

All I see is what you see when you search :smiley:
Posts like this - http://www.000webhost.com/forum/customer-assistance/31860-fatal-error-allowed-memory-size-67108864-bytes-exhausted-tried-allocate-7680-a-2.html#post171106
Seems a hit and miss workaround from what people say.

This was always to do with plugins/addons in the past I think and for me the easy way round it was to manually install them.
Is this now relayed to something else aswell?


#12

You can also check wp-config.php here and set the value.

define(‘WP_MEMORY_LIMIT’, ‘128M’);


#13

thanks all i just fix my website
game offline pc


#14

worked for me with FREE hosting.


#15

Hello,

I set up new wordpress 3.7.1 installation and only thing I did was to migrate database from different host and changed language to czech. Site worked perfectly till tomorrow.

Now I am getting:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 30720 bytes) in /home/a5531367/public_html/wordpress/wp-includes/default-widgets.php on line 846

I followed all instructions mentioned on this forum and had no luck yet.

Can anybody point me to some direction like “you have to reinstall wordpress”?


#16

I followed all instructions mentioned on this forum and had no luck yet.

What have you tried?


#17

Just paste this

define(‘WP_MEMORY_LIMIT’, ‘128M’);

in your wp-config.php file
and refresh your dashboard page


#19