How to install flarum forum on 000webhost


#1

Flarum is incompatible with 000webhost.
However, I found a workaround, to get flarum installed on your 000webhost app, easier than the flarum official installation.

Steps

  1. Download this file.
  2. Upload it to your website.
  3. Create a new database.
  4. Go to yourwebsite.000webhostapp.com/install.php
  5. Fill in the form with the required information.
  6. Success! You have successfully installer Flarum forum beta 7.

NOTE: This is the easiest forum install you will ever find!
Your website should have no files in it or the installation file should be in an empty directory

Here is a sample of a 000webhost installation
https://talk.myhexa.co


Site not working 500 Error
Want One Forum Here
Xenforo error can someone help me out
Create a forum, be able to edit database
#3

header-hexa-flarum-plugins

HOW TO ENABLE PLUGINS:



  1. Go into your file manager

  1. Search for the file “config.php”

  1. Find the debug section and change “false” to “true”

  1. Save the File

  1. Go into your Flarum Admin

  1. Enable the extensions you’d like

  1. When done enabling them, change “true” back to “false”

  1. Repeat these steps if you need to enable an extension again


Hope this mini-tutorial helped! If you have any questions, feel free to PM me! :slight_smile:


#4

how do i change the colours and the welcome message?


#5

Hi @Saxo_Broko
You can easily change them in appearance section of your administration panel


#6

I Follow Your Steps, But First Time Install Get Error 500, Then Second Try To Install It Run, But Blank. How To Fix It, Console Sometimes Appear Error 500 msg.


#7

What is the website in question?


#8

Deleted,tmr i will try again. If can’t i reply you again.


#9

@HowToDoThis is this working for you now?


#10

@ckhawand till Not Working. Tried Use Fix Files Permission Still Showing This Error.

This page isn’t working

[RemovedLink].000webhost.com is currently unable to handle this request. HTTP ERROR 500


#11

@HowToDoThis Can you please try my installer and see if that works for you?

Simply download the repo, extract to your website, and then move all the files to where you’d like. Don’t unzip installer-files.zip :slight_smile:


#13

Okay, I found WHY It’s Not Working. Because I Use web file To Extract, then always Get 500 Error Code, but I Try To Use Filezilla To Give A Try, It Works. Now Running. Thanks :slight_smile:


#15

Glad to hear it! :slight_smile: Good Luck! :wink:


#16

How do i setup the smtp part because everytime i do it i have trouble first i used mailgun then i switched over to google but neither worked, i need this so people can verify their accounts. Also how do i get added html into the flarum header


@hexa Signing up and logging into https://talk.myhexa.co doesn’t work
Signing Up

Logging In (when false credentials)


#17

That is odd. I was able to create an account and log in. Can you try again? :slight_smile:


#18

it works now but didn’t before :confused:

also question from the last post
How do i setup the smtp part because everytime i do it i have trouble first i used mailgun then i switched over to google but neither worked, i need this so people can verify their accounts. Also how do i get added html into the flarum header?


#19

You can add HTML to the header in your admin dashboard under “Appearance”. For SMTP, try Zoho. :wink:

https://mail.zoho.com


#20

zoho doesnt accept my TLD *.ga


#21

How do i setup the smtp part because everytime i do it i have trouble first i used mailgun then i switched over to google but neither worked, i need this so people can verify their accounts. Also how do i get added html into the flarum header

You didn’t answer my question


#22

Alright, for SMTP part I really don’t know what you can do than upgrading.
For custom header, there should be a plugin that does that.


#23

Hi @Saxo_Broko
As @ckhawand said right.
You can try sendgrid also and you can customise header in administration menu