https://amierdance.000webhostapp.com/admin.php


#1

cannot use session_php
is it able to turn on the session.auto_start?
mysite is : amierdance.000webhostapp.com
many thanks


#2

Did you put session_start(); at the beginning of your PHP script?


#3

Yes, I’ve put session_start() at the beginning of my php code
I encounter the same problem (session not remain when page chnges)on my localhost,
and solved by change session.auto_start into ‘On’ in php.ini


When I check the phpinfo on 00webhost
It seems the default setting of php in your host is ‘Off’…
thus, please help adjust the setting of session.auto_start into 'On’
Million Thanks …


#4

Is there a tmp folder in the / folder?


#5


yes, there’re [tmp] and [public_html] in [/] folder


#6

Let me forward that to the developers


#7

Can you try now?

@amierDance


#8

tried, but not work either…
the session is still not being preservered
I notice in 000webhost is not enabled [session.auto_start] right now


which I was solved the problem by turn on [session.auto_start] into ‘On’ on localhost
is it able to switch that on for a test ?
thanks…


#9

We can’t change PHP parameters on the free plan unfortunately.


#10

Can you try now please?


#11

wow !! that’s amazing, it works… thank you very much

wish to know what’s the change of the setting


#12

Check your .htaccess file :slight_smile:


#13

Can I ask what actually had been changed here?
I have very simmilar problems. Only thing in .htaccess is php enable errors, also my session files in tmp are being created, but are empty. I use exit() after header, I start with session_start() everywhere.

Check your .htaccess file :slight_smile:


#14
php_value display_errors 1
php_value session.auto_start 1

Is the contents of his .htaccess file.