Https://mydomain redirects to https://mydomain.000webhostapp.com


#1

Just received an active certificate from cloudflare.com and it works. Put in the correct cname records for www.mydomain.biz and mydomain.biz pointing to 000webhostapp.com.

Now when I browse to https://mydomain.biz it redirects to https://mydomain.000webhostapp.com,
How can I have it stay at https://mydomain.biz ?

thanks


#2

@mimikveh2 Go to your wordpress general setting and change “site” and “wordpress” url to your domain name.
This will solved your issue.


#3

Hi thanks for your answer but I still have a problem, I have a certificate from cloudflare and therefore put my wordpress address and site url as https://www.qace.biz. however it shows as not secure?

Your connection is not private

Attackers might be trying to steal your information from qace.biz (for example, passwords, messages, or credit cards). NET::ERR_CERT_COMMON_NAME_INVALID

If in wordpress i put www.qace.biz and browse to https://qace.biz it works but lands on the unsecure www.qace.biz?

please help. BTW by default the wordpress was SSL https://qace.000webhostapp.com ?

Also now I can’t get into wordpress anymore:

https://www.qace.biz/wp-login.php

This page isn’t working

www.qace.biz redirected you too many times.
Try clearing your cookies.
ERR_TOO_MANY_REDIRECTS


#4

You need to install a plugin called "SSL Insecure Content Fixer` from your Wordpress dashboard. Configure the plugin and it will fix this issue and allow you to use HTTPS on Wordpress.


#5

I did install and site still is problematic:

Https://www.qace.biz


#6

Hi @mimikveh2!

Please go to WordPress cPanel > Settings > URL and change all URLs to https://qace.biz


#7

http://qace.biz

Seems to be working fine?

Remember if you are going to use a custom domain like qace.biz you need to stop using the 000webhostapp URL


#8

now that I changed the settings to https://qace.biz I can’t get into WordPress cPanel anymore:

Its been almost two weeks and I can’t get this right???

I did clear my cookies. How am I supposed to get in now without resetting the whole site like I did almost 10 times arleady?


#9

now that I changed the settings to https://qace.biz I can’t get into WordPress cPanel anymore:

@Infinity @akhilkumar332 @sulliops

Please fix this issue. I would fix it myself but I have no access to 000webhost database…


#10

@NGiNX @mimikveh2 Website is working fine now,


#11

are you kidding me, its supposed to be https://qace.biz
and can’t get into wordpress cpanel anymore


#12

I have sent you a PM.


#13

what’s a PM private message, where is it?


#14

PM stands for “Private Message”.

You can see the message by going to https://www.000webhost.com/forum/u/mimikveh2/messages


#15

Has this been resolved?


#16

you guys have been over two weeks putting me in circles while I finally found the solution here:


#17

Theoretically, changing the address from WordPress cPanel to HTTPS should act the same as Cloudflare’s Always use HTTPS rule, for links related to Wordpress…

Good job for finding the fix, though :smiley:


#18

We provide support for 000webhost.

If you are using CloudFlare then we can only guess, if you need concrete answers you should have gone to CloudFlare…


#19

Thanks mimikveh2.

After following the instructions in the link, I had to also go to the Cloudlfare => crypto => Automatic HTTPS Rewrites => Yes

Then I installed the plugin in wordpress SSL Insecure Content Fixer and all the errors seemed to go away.


#20