HTTPS Not Private


#1

Hello,

I’m having trouble with https on my site https://bitpcs.com

bitpcs.com will load, but not securely.

I bought the names bitpcs.com & bitpcs.net with GoDaddy
Developed the site with 000webhost Website Builder
Set the DNS(for bitpcs.com and bitpcs.net) in GoDaddy to ns01.000webhost.com & ns02.000webhost.com
Forwarding(GoDaddy) bitpcs.net to bitpcs.com
Parked bitpcs.com with 000webhost and pointing to bitpcs.000webhostapp.com

What am I missing…?

Thanks!
TomX


#2

Check out this tutorial to add SSL to your website


#3

Thanks for the reply,

I read this post, but was confused as to whether or not I am to use ns01 and ns02 as the nameservers instead of GoDaddy’s.

From what I read (without doing the setting of the @ and www records) it is suggesting to use GoDaddy’s DNS?

Do we use NS01/02 or GoDaddy for DNS?

Thanks,
TomX


#4

No…

Update the Name Servers to the ones which Cloudflare provides to you.


#5

I don’t know what CloudFare is, I am not using it.


#6

000webhost provides signed certificates only for *.000webhostapp.com URLs.

Your only choice is to use Cloudflare if you want to get rid of the security error. Else, use http:// instead of https://

Also, your domain is parked correctly. :wink:


#7

It depends on your choice.

If you want you can either park your domain to 000webhost or point it with CNAME records. If you point it with CNAME records you will still be able to use your registrar for DNS settings. Also, for CNAME pointing you’ll need to keep your registrar default NameServers.

If you park it using Name Servers then you will be able to use only our limited DNS management (which allows you to add only one MX record).

It depends on your choice. However right now your domain is parked correctly. Unless you need more control, keep it this way :wink: