I need to refresh my website to get it


#1

French user here :smiley:
I made my website but when i open it the first time i must refresh it to have it all.

I don’t know why :frowning:


#2

Hi @Thobas!

This usually happens because of old cache. Please clear your browser cache and retry :slight_smile:


In addition, what is your website address?


#3

thobas.net !
And how can i do this ? :o


#4

Hit CTRL+SHIFT+DELETE and delete all cache (make sure you delete just the cache, not other stuff).


#5

Ok it’s done and yeah it works !

But idk because my friends got the problems, and if i need to send it to people i cant tell them “clear thecache” xd


#6

I am not sure what exactly is cached. I believe it is the mixed content (linked JavaScript/CSS). The browser does this automatically to minimize the transfer between Client <---> Server.

Please append the following code to .htaccess. It may increase the server loading but it should help you get rid of cache issues.

Header Set Cache-Control "no-cache, no-store"

NOTE: I suggest you to use the upper solution only when your application is in development mode and you need to see the pages being updated in real time. In production mode it will not be useful because the cache of any browser is purged automatically either after the browser is closed, either after a certain period of time. Your clients may not be affected at all by this :slight_smile:


#7

im really sorry i don’t understand what i need to do …


#8

I did it for you. Please read my upper answer.

To disable the current mode, go to /public_html/.htaccess and remove Header Set Cache-Control "no-cache, no-store"

To re-enable it, add the string again. That’s all :slight_smile: