Installing extensions in Joomla failed with error: Copy file failed

matat.000webhostapp.com
I installed the Joomla system by uploading it in the online file manager, where I extracting.
The installation went fine and the site went up, perfect!
But every extension I try to install fails the error above.
I have tried all kinds of solutions within Joomla, but there seems to be no connection to CMS but to server.
I deleted the files and re-extracting, and reinstalled, the problem remained.

I completely deleted the database and created a new one.
I uploaded a new Joomla file from an older version, the problem remained the same!

During all these steps, I also tried to change folder permissions, at least temporarily for it to work, but there is no difference.

I can’t figure out what the problem is, I suspect there may be a problem with proper file ownership.
In addition, I have tried the “Troubleshoot and Fix Your Website” in the admin panel, again, no difference.

Thank you very much for your help!

I think at a guess Joomla exceeds the free plan limitations, looking online there are threads mentioning Joomla exceeds 50,000 indoes and our free plan as far as I am aware is around 10k-20k meaning you’ve just likely breached the free plan limits and the process is coming to a halt.

Try alternative free hosting or upgrade for about $20 a year?

The limit here is 10K indoes, which is really very low for Joomla.
And no, that’s wrong, because I really use it to learn it.
It’s also website building and open source. I don’t understand why you are restricting to WordPress.

But anyway, I don’t think that’s the problem for two reasons:

  1. Statistics tell me I only use 85%
  2. I uploaded the files manually and extracted them, The server was not prevented.
    So the files are already there and I’m still fine in terms of restriction.
    But it still doesn’t work!

I’ve really tried other alternatives, but note, yours is faster! :wink:

Well I Googled for

Installing extensions in Joomla failed with error: Copy file failed

It seems to be something about permissions or similar?

Maybe open a topic with Joomla as I’m not sure this is a 000webhost hosting issue and more of a script issue.

If there is no help here, this is what I will have to do or move to another alternative.
I installed Joomla on a local server on my computer, installed on other free servers, and did not encounter this problem.
And like I said, I have retried some versions that work perfectly everywhere.
I also suspect this is a permissions problem and I tried to change, but it didn’t help.

Thank you for trying to help !! :blush: