Laravel .env can't be accessed but worked fine a week ago


when I want to login this error is shown…
SQLSTATE[HY000] [1045] ProxySQL Error: Access denied for user ‘forge’@‘2a02:4780:bad:f00d::16’ (using password: NO)
But it worked a week ago and i didnt change anything. later i changed my password /deleted cache/session/config but everything gone in vein :weary:


What do you mean?

You are getting issues logging into your 000webhost account?


I can login fine into my account… but i cant login in my website


Is it a wordpress site?

#5 its my site and its laravel website… First I faced App_key problem but i was able to suppress it by pasting app_key directly in config/app.php but tthen database connection problem arise and its clearly indicate that my .env file is not working…i dont know why because last 7days ago my site was fine…


Oh I see, I think a moderator will help you more on this. One of them will get back to you soon, we appreciate your patience.

@ckhawand @Ayu @teodor


/half solved by configuring config file manually since .env is not being read



I am having the same problem which i cant access my website because can’t access to database.

I checked the database name, username, password i keyed in into .env many times. Names of all these are exactly the same as database i created in 000webhost phpadmin.

I would really appreciate any help…


‘log_level’ => env(‘APP_LOG_LEVEL’, ‘debug’), //its best practice as putting default value
‘log_level’ => env(‘APP_LOG_LEVEL’), // its not wise to do .its completely dependent on .env file.
its not best practice for server.
butw if this problem occur in locally then simply do “php artisan config:cache” artisan command

now check /config/ and check all files on there and do it…I think it will help you


Can you tell me what is the name of the file that should be modify and where?

I have no problem running my website locally. The problem i was referring was in 000webhost.

I dont think i touch anything, but now this is what my website shows:


if it is built by laravel framework
first turn on debug mode /config/app.php
‘debug’ => env(‘APP_DEBUG’, true)
and see whats error is shown specifically



Please check the FAQ section from here.


Resolved now :sunglasses: :slight_smile: