Migration Discussion


#201

Alesap if 503 or 500 then download files manually using FTP

As per tutorial if your site is too big the free limits in place break the backup operation.


#202

thanks :slight_smile:I can indeed add my old domain and then redirect it to the old name (I tried one of the three). But it has no www. in front of the name. How can I add this www (www.wiskunde1en2.net63.net) ? thank you for helping :smiley:


#203

@cckj Sry you can’t add “www” to free sub domains.

Else grab a free domain from “freenom.com” and park it using name servers, then you can use with “www”.


#204

Thank you @akhilkumar332 for your answer, I 'll try it :slight_smile:, but all those years my free subdomain was www.wiskunde1en2.net63.net. All my links and papers refer to this name with www. :sweat: Is this a new policy of 000webhost. Why in the old panel with www and after migrating without www. ? :sob:


#205

Yes, Because as per the admin there’s no use of “www” for free subdomains.


#206

Hi, I’m having this error while trying to import my old database. How can I fix this? Tia!


#207

I got this error too and the answer might be simple.

You might be not familiar with this version of phpMyAdmin. I was not.

There should be a left (navigation) panel.

Because there is just one database, one may decide not to touch
anything on that panel and go straight to the right.

But now, this is not the case.

You need to select/hightlight your database name in the left panel
first before doing any actions on the right.

Otherwise it will think you are referring to something else.

Try that.


#208

Hi, I just noticed that I need to migrate to new cpanel. Maybe I would appreciate something more than just one email notification. Normally i would submit this as a new ticket in customer support, but I can’t find anything like that on the new website…

When I wanted to log in to my account, it seems it does not exist anymore. I had to sign up like a new member for this new Cpanel. And I can’t get to the old one - I guess it does not exist anymore??? It’s not 1st May yet, what am I supposed to do not to loose my website? www.tourdelife.eu I found this very disturbing.


#209

This worked thanks a lot! Altho now I’m having a different issue :

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /storage/h14/765/1508765/public_html/storescripts/connect_to_mysql.php:19 Stack trace: #0 /storage/h14/765/1508765/public_html/index.php(15): include() #1 {main} thrown in /storage/h14/765/1508765/public_html/storescripts/connect_to_mysql.php on line 19

I’m pretty sure the database name, pass and host are correct.


#210

@wolfywolfy You are trying to us deprecated mysql function.
so downgrade your php version to 5.4 from “settings” – “general” – “php version”.


#211

Thanks for your reply. I tried it but now it gives me this error :

Warning: mysql_connect(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /storage/h14/765/1508765/public_html/storescripts/connect_to_mysql.php on line 19
could not connect to mysql


#212

@wolfywolfy Host is “localhost” .
Double check that you used correct database details.
You can find database related details in “Manage database”.


#213

Weeks ago I began the migration process, but I stopped after the “Move website” step since some of the instructions seemed unclear and some people were having a lot of problems. Today I resumed the migration process because the email I received weeks ago said May 1st is the deadline for migrating. I accomplished some of the steps: registered my free subdomain, uploaded my backed-up files, and set the PHP version to 5.4 (due a function that doesn’t work with PHP version 7). When I tried to launch the site, I got an error message that said the site was missing an index file. The old site used ‘default.php’ as its entry point, so I renamed it ‘index.php’. Now when I launch the site it tries to load the index.php file, but it fails to execute properly. PHP code is supposed to be enclosed within the pair of tags ‘<?' (begin php code) and '?>’ (end php code), but seems to be treating the first greater-than symbol (’>’) after the ‘<?' tag as if were a '?>’ tag instead of a ‘>’ operator. (Thus the php code that follows the ‘>’ is processed as if it were html markup.) How do I get the new site to allow the greater-than operator to be used in php code?

My website is extremely simple. It just has the single .php file. No database.

One more question: The content of the .htaccess file created by the migration isn’t the same as the old .htaccess file. Should I use the old file or the new? Should I copy any of the lines from the old file to the new?


#214

25 posts were merged into an existing topic: Migration Discussion


#215

Seems you’re using php short tags (<? ?>)
You need to follow this tutorial in order to use php short tags.

Or you can use universal type tag to avoid the issue you faced.

Yes you can if it is required.


#216

I don’t know if any lines from the old .htaccess file are required, since I didn’t create either the old or the new .htaccess files and I don’t know what they do.

I replaced the short ‘<?’ tag with the long ‘<?php’ tag and that helps it get further. (Thanks.)

Now it displays an “undefined variable” error message inside a data entry textbox: “Notice: Undefined variable: BallotsTable in /storage/h12/537/1509537/public_html/index.php on line 1028”

Line 1028 actually contains $BallotsTable, not BallotsTable. Here are lines 1025 through 1029:
$action = $_SERVER[“SCRIPT_NAME”];
echo “^FORM ACTION=”{$action}" METHOD=POST>\n";
echo “^TEXTAREA NAME=“BallotsTable” COLS=70 ROWS=10>\n”;
echo $BallotsTable;
echo “^/TEXTAREA>^BR>\n”;

(EDIT: The ‘^’ characters in the above code actually represent ‘<’ characters. This forum mangled the display of the code when I used the actual ‘<’ characters.)

Are there php configuration settings from my old site that need to be restored? I don’t see any in the files I backed up (which were the files in the public_html directory).


#217

Hello? Can yo answer my problem and not ignore me? Why can’t I log in to the old pannel, the suggested link doesnt work: https://www.000webhost.com/cpanel-login?to=old this only redirects me to the new panel, when I log in there it’s completely empty.


#218

@GeoffreyS Can you downgrade your php version to 5.4 or which ever suitable
See if this helps.

or

Double check those lines once.[quote=“GeoffreyS, post:251, topic:56245”]
I don’t know if any lines from the old .htaccess file are required, since I didn’t create either the old or the new .htaccess files and I don’t know what they do.
[/quote]
If you have not created ,any then don’t copy any.


#219

@cascy can you PM me your issue?? It’s bit messy here.


#220

Thanks for the reply. So today I noticed that if I want my website to be on I need to migrate. When I tried to log in, it was like a new registration, I received an email that I have to verify my account - that should not happen when I already had an account under this email.
Anyway, I logged in, verified my email and the account really is like new…there is nothing about my website which was running until yesterday (www.tourdelife. eu). The account is completely empty, like new one. So I can’t do the migration process - I don’t see and can’t access any data.