My own domain redirecting to 000webhostapp.com address


#1

Hello guys!

First of all:
1 - I’m a beginner about web hosts and i dont know nothing about upgrade files, but i would do it if i receive the instructions.

2 - I’m not a native english speaker, so, sorry for any problem, i will try to be the most clear possible.


So… I set my own domain on the panel and always that i put it on browser it redirects to the 000webhostapp.com address version of my website. The links are: http:// timwaves.com / http:// timwaves000webhostapp.com

I thought that i should change it on the Wordpress panel, to be redirected to my own domain properly, and i did it, and it worked, but it gives SSL problem, and so i receive an information that my browsing is not secure.

I read in another thread that it could be a problem because the database have a different authentication, that is of 000webhostapp.com, and so i should create a new SSL. I watched to some tutorials and goed to cloudfire, created an account, choose the nameservers to the ones that they recommended on my registar, did some sets into the Wordpress panel, like connect the Cloudfire plugin, enable flexible SSL, activate on Cloudfire account, etc. But some minutes after i could not access neither my website or Wordpress panel. I thought it was because of the change of the name servers on my registar.

So, i returned the set of the name servers on my registar to the 000webhost ones and both website and Wordpress panel returned to be accessible again.

Questions: Could i just make all the settings on the Wordpress panel, Cloudfire account, but keeping the name servers of 000webhost on my registar and so, when i change the address of my website into the Wordpress panel have SSL working properly when people visit it using HTTPS? Would exist another way more simple to do it?

Some things to consider:

1 - I have another website that i am also going to use as Wordpress and made the register here on 000webhost too. The domain of this other website is http:// recallfm.com. I did everything the same with both, parked the domains into the panel and set the 000webhost name servers into my registar, but this on is working fine, it’s not redirecting to the 000webhostapp.com address version, but my timwaves one is. What could be wrong? Maybe any Wordpress plugin could be do it?

2 - I got both domains on Godaddy about one year ago, i am migrating both from Blogspot to Wordpress and decided to use 000webhost free service, at least in a firt moment for tests.

I hope someone can help me!


#2

Check this tutorial and let me know how it went for you


#3

Thanks for the answer!

But how i said before, already did it and works, but gives SSL error (what i think would not be cool to my clients when i share the link with them). So i tried to make a new SSL via Cloudfire, but my website and Wordpress panel started to be inaccessible. So, i paused the domain on Cloudfire and redo the name servers of 000webhost into Godaddy and the website and Wordpress panel just got back.

So, if i do this procedure on the link i have SSL problem. If i keep without to it, i have redirection to the 000webhostapp.com address version.

Again, the other website that i have into the service have the exact same settings (including any alteration of the URL into Wordpress panel) and it is working fine.


#4

Well, actually now i am having both: Problem with SSL autentication and redirection. Should i just delete my account and create the website again, since the other one is working properly? Or axist any possibility to solve it? I would not like to upload all the files again, remake all the settings on layout, recreate all the pages, etc…


#5

There is no redirection to *.000webhostapp.com url.
Your site “timwaves.com” loads fine…without ssl.

If you want ssl then connect it with cloudflare.

If i’m missing something, let me know.


#6

Yes, because i did the change that i mentioned. If i go back to no alterations on the Wordpress panel, so i get back the redirections.

The problem with Cloudfire is that when activates i was not being able to access my website and panel, or i was doing something wrong?


#7

@timwaves if you using wordpress then, you need to change the wordpress and site url to your domain name “timwaves.com” from your wordpress general settings, so that it will not redirect to *.000webhostapp.com.

eg:-

Sometimes it take time to activate ssl, so meanwhile you can use “http”.


#8

Ok, already did it and already not redirecting.

How should i properly use Cloudfire to be free of this non secure initial page?


#9


Check this tutorial on how to use cloudflare for ssl.

If you’ve any issue you can post here.