No se ven imagenes


#1

Hola, 1º disculpenme por el titulo ya que busque en gogle y no encontre solucion.

Os explico, despues de crear mi web en html la subi en este host y no se veian las imagenes, busque informacion de el porque no se veian y las respuestas eran que no se veian por una ruta incorecta o que no estaban en la carpeta imagenes, asi que hize un web simple en html con un fondo.jpg un comentario en body y una imagen llamada logo.jpg en body. Lo subo con filezilla y accedo a la web con internet explorer. Solo se ve el fondo correcto el comentario correcto Pero la imagen que puse en body no se ve solo aparece un cuardrado pequeño.

En mi pc cree una carpeta que contiene ( index.html, fondo.jpg, imagen.jpg )en mi pc se ve todo pero en el host no se ve la imagen, solo el fondo. No creo que sea culpa de la ruta ya que es simple. Os dejo el codigo de la web simple.

Esta es la pagina para que lo vean:

El archivo index.html, fondo.jpg, y logo.jpg estan dentro de la carpeta public_html

Este es el codigo del index:


<html>

<title>Titulo de la solapa web pagina

</title>

<head>

head cabeza principio de la pagina web

</head>


<body background="fondocolor.jpg" text="red">

<p></p>

<img src="imagen.JPG">


</body>


</html>

Gracias a todos.


#2

Hola,

El problema puede ser debido a que estás en un servidor Unix y nombres como imagen.JPG, Imagen.jpg, imagen.jpg, IMAGEN.jpg, para el servidor son nombres totalmente distintos. Debes respetar (escribir igual) las letras mayúsculas y minúsculas.
Por lo general se recomienda usar nombre de los ficheros con todas las letras en minúsculas, aunque es sólo una recomendación.

También a la hora de nombrar los ficheros es recomendable evitar letras especiales como Ñ, letras con tilde, (á, é, í, ó, ú) y espacios en blanco.


#3

Gracias, esa respuesta la vi en algun foro, si esta todo en minusculas los 3 archivos dentro de public_html. Puedes observarlo desde el codigo fuente de la pagina si accedes el fondo que seleccione es .jpg y se ve perfecto en la web pero la imagen que puse en body no se ve y tambien es .jpg por lo que no entiendo que lea el fondo y la .jpg del body no.


#4

Algunas observaciones.

Además de poner los nombres de los ficheros con las imágenes que subas al servidor en minúsculas, luego en el código HTML que escribas, estos nombres también deberían ir en minúsculas. En tu código aparece el nombre del fichero como “logo.JPG”.

Aunque por lo general te pueda funcionar, tu código tiene otra pequeña errata. La etiqueta <title> debe ir dentro de la etiqueta <head> . <head> es la cabecera, en la que hay que poner entre otras cosas la etiqueta del título <title>, como dentro de la etiqueta <html> estás guardando todas las etiquetas.


#5

Ahora lo cambio y miramos Gracias


#6

Ok,

Veo que ya está funcionando bien.


#7

Si amigo acabo de cambiar title a dentro de head y seguia sin verse el logo, ya me di cuenta de que logo estaba en JPG mayuscula disculpeme, era simple pero no lo vi ahora repasare la veb completa y la subire y ya le cuento.

Mil gracias.


#8

Recuerda, que cada vez que hagas un cambio en los ficheros en el servidor es muy recomendable que limpies la caché de tu navegador para que se muestre la última versión con los cambios que has hecho.

Esto lo puedes hacer también actualizando la vista de la web pulsando al mismo tiempo las teclas Ctrl+F5 con el navegador y la web que quieres actualizar en pantalla.


#9

Mil gracias amigo ya esta funcionando perfecto no me di cuenta que las imagenes estaban en jpg Mayusculas ese detalle me bolvio locaaaaa.

Solo una ultima cosa al abrir cada apartado de la web tarda como 1 o 2 segundos en cargar se ven los recuadros de las imagenes en blanco hasta que se cargan y todo bien.

¿Faltara algun script? Para que cargue bien ?

Gracias.


#10

Hola,

Creo que el retardo se debe más al tamaño un poco excesivo de las imágenes. Deberás utilizar un optimizador de imágenes. Estos programas que puedes usar incluso en versiones online para la web reducen el tamaño de los ficheros de imagen sin que éstas pierdan calidad.


#11

Muchas gracias amigo puedes dar el tema por solucionado.


#12

Hola soy nuevo subiendo paginas web y las imágenes no me cragan en mi pagina ayúdenme por favor.