Parked domain without www taking longer to enable?


#1

Hi,

I’ve noticed in my last 3 migrations that the domains without the www are taking longer to enable.

A recent example is:

www.relatos.tk <- this one works (I know there is nothing, I did not upload anything yet)
relatos.tk <- this one is the same domain, but without the www and it doesn’t work yet, as you can see

I had the same issues (fixed in some hours, automatically), with the websites:

emexico.tk (www.emexico.tk)
akira-webdesign.tk (www.akira-webdesign.tk)

First only the ones with the www works, only after some hours the naked ones begin to work.

Is this a fact or I’m missing something? Because I really need the websites working properly with the www and without it and in the case of relatos.tk I’m waiting for hours and yet it did not work.

In the members area it’s already set and parked relatos.tk and as a subdomain www.relatos.tk (again, automatically).

Is this normal, to take longer the naked domain?

If it’s not, what I am doing wrong?

I did not change any CNAME in my other domains, it’s exactly the same for every domain of mine hosted here.


#2

You aren’t doing anything wrong, you just need to clear your browser cache. [quote=“everkane, post:1, topic:67459”]
without the www and it doesn’t work yet, as you can see
[/quote]

The issue is that your browser keeps a stored view of the site, like a memory. We can all see the same thing on both WWW and non-WWW for all three domains.


#3

Are you sure?

Because in the relatos.tk I see the website:

“Since May 1, 2017 your website should be switched to new members area.
If you still need your website follow instructions below.”

And in the www.relatos.tk I see:

“Hooray, your free website has been started!”

I just cleaned the cache, it did not change anything.

I’m gonna put a proper index.html because they are indeed very similar (but not the same)


#4

I’m sure, it works fine. You just need to clear your browser cache, as I stated before.


#5

I’m sorry but I think you are wrong, mate.

I just checked in my smartphone, they are not the same at all.

I’ve put a proper index.html like I said because the old one was the 000webhost default (very similar to the “migration advice”)

I’m pretty sure you can see the difference now.

If you don’t, I don’t know what to do because I cleaned the cache twice and tried on my smartphone as well.

Obs: the other 2 websites I know they are working properly, but like I said, the naked domains took some hours to work


#6

Nope, and I have screenshots to prove it.

:arrow_down_small: WWW Version

:arrow_down_small: Non-WWW Version

Notice how the same exact text is shown on both WWW and non-WWW, and the arrows are showing you. All I have done is added arrows and blurred my personal stuff. If you need further proof, I can record me visiting each page individually.


#7

Ok, thanks, but I really don’t know what do to.

I’ve cleaned the cache, I’ve tried in my smartphone, I even flush DNS.

For me, the relatos.tk is redirected for this one: https://www.000webhost.com/migrate?utm_source=000&utm_medium=rdr&utm_campaign=old_panel_off&static=true

The www.relatos.tk shows “under construction” properly.

=/


#8

Try one of these tutorials, use the one that corresponds to your operating system.

Also try restarting your router and/or modem (if you have one) because it could be that your network needs to catch up.


#9

Ok, I will, but the DNS is already parked on 000webhost for the last 2 years since I had this domain on the former panel, so I really don’t think it’s a problem of DNS resolution. Besides, how the www is working for me and the naked one is not? It doesn’t make sense being a DNS resolution problem.

Like you said, the browser cache would probably be the issue, but I’ve cleaned already.

I’m gonna try with other browser, I just need to download it.


#10

DNS resolution is different from DNS records. Your DNS records are fine, but your local system needs to be cleared. Try using that or another browser.


#11

In another browser it was fine, but yet I was not convinced because it was redirecting automatically to the www one.

So I did what was written on the tutorial, then flushed the DNS again.

It is working good now. I mean, there is still a favicon of 000webhost in the naked domain (the www does’t have it), so it’s pretty weird, but I think it’s not a problem here at all.

I have to say that if I go back to the automatic DNS at ipv4 the problem comes back, so I’m still worried about how the older users are gonna see the website without flushing their dns.

Thanks for helping.


#12