Pointing CNAME isn't working


I’ll try to write a tutorial later.


Thanks Infinity :slight_smile:

It did the trick for me with temporarily pointing name servers of my SLD to 000webhost. But it can be problem for some people during the temporary phase of setting the things to work. Luckily, I was not having any important service running through my registrar’s name servers, so it would be good if Point Domain starts working.

Once again thanks for the help and your efforts. :slight_smile:


I’ll try that, but first let me ask something about how to do it.
Do I have to have 2 sites on webhost, one to park the canonical domain and another one to link as a subdomain? Is that right?


It worked changing the DNS temporarily and restoring it back. Tyvm!

Can't set the domain

Any word as to when this will be fixed? I can’t switch my DNS, even temporarily, so the workaround doesn’t apply to my case.


Hi infinity,

I have exactly the same problem Gabe had on January 12. I can see he had solved it but he didn’t post here how he did.
Please be so kind to let me know how to solve this problem.
Thank you very much in advance and have a nice day.


What post?

If you mean gbrenner526/Gabe & post "I own my domain through 1and1 and pointed CNAME to my 000webhost website. "

He has resorted to using nameservers from the looks of it.

If this is the post you meant, else if not please do link to it :slight_smile:


Hi infinity,
your post is 27/27 … his post (the one I mean) is 3/27
I do not know how to link it. sorry.


Sorry still confused.

What issue are you having/ what are you trying to do?
If you are having CNAME issues just use nameservers.



I own my domain through 1and1 and pointed CNAME to my 000webhost website. When I type my domain in (www.pastelmusicxx.com) and attempt to visit my website, I get this:

Screen Shot 2017-01-07 at 11.04.06 AM.png1280x718 14.9 KB
Whenever I try to point my domain in the control panel, I get this error:
Domain www . pastelmusicxx . com CNAME must be pointed to pastelmusicxx . 000webhostapp . com
However, CNAME appears to be set up correctly through 1and1, so I can’t seem to figure out what the issue is.



He fixed his issue by using nameservers as I screenshot above his records are pointing to 000webhost now.


I have tried nameservers three days ago but it didn’t work


the cname method points to my 000webhost site now, but it is still not working,
Please check www.yehia.net


are you still there my friend


Loads to 000webhost but is having a config error.

If you can set your domain to the CNAME instead of www.yourdomain if that makes any sense but I think you need an A record for that to work, some domain registars are a bit weird.

Best off using ns01.00webhost.com and ns02.000webhost.com and using the top option on the add domain window.


How do I fix this error?


Up to your registrar to allow you to use CNAME in a better fashion.

Better of using nameservers honestly so much easier if I had any input I would remove the CNAME function altogether.


Ok thanks … I’ll try the nameservers again.
Thanks a lot