Problem with MVC


#1

hi

I’m trying to make an mvc and had put all the files I thought I needed on the file manager but it still asks for an index page. can anyone tell me why?

Do I need to build my mvc in an application such as netbeans coz i’ve just been using notepad++


#2

What is your website URL


#3

i’m not sure, i thinks it’s https://kimfrederic66.000webhostapp.com/


#4

mvc probably won’t work here will it?


#5

yeah i had a feeling that would be the case but thought I would try as it is a final year uni project and I wanted to do a good job. I’ve been reported and kicked off anyway


#7

@kf100 MVC is a framework and it should work. Make sure it is php compatible and yes you do need “index” file.


#8

@akhilkumar332 appears for me to be a 000webhost system issue, he actually has an index.html file, and a .htaccess saying that the indexes are index.php index.html index.cgi


#9

Its should be an “index.php” not “index.html”, as index file contains some php functions.
That’s how MVC works.


#10

Wait a bit, @kf100 did you delete the index file?
At the time I checked your website (18mins ago), there was one :confused:


#11

I’m not sure there was an index in public_html but my index was definitely php, but I had a whole bunch of folders and I only put up enough to get the registration and login going.


#12

i deleted the whole lot and then sent a message on here, went to redo the whole lot again and got blocked. I can’t do anything now


#13

can you upload your content again?? for us to check for issue :slight_smile:

@ckhawand Are you sure that was “index.html”, as @kf100 says it was php.


#14

will do now that I have access again


#15

right, i have everything that I have so far in there.


#16

Like Akhil said, index.php is missing


#17

is the file structure ok? would it worked if i defined the url in the dbconnect or does it have to have an index.php file


#18

The index.php page is the one that calls other, so it is essential


#19

silly me saved the index in the wrong place. there is a place to define the url on the dbconnect, would that be the one above or something else


#20

Try moving the index to public_html then :slight_smile:


#21

that worked but now i’m having trouble with links to pages. I’ve tried all sorts of things but nothing is working