Problem with the https


hello can some body help me please am trying to make https connection from it send me the file and i crreated the folder with the name .well-known and inside it anothor folder acme-challenge
but when i go to it it says the folder acme-challenge dosnt exist and am sure its the correct path


This will help


should i change the webhost nameserver in my domain nameserver to the cloudflary or i should just added them to with my nameserver


should i put the servernames from cloudflary under or i should replace them with the cloudflary nameserever


Hi @AwadGorg!

Use Cloudflare’s Name Servers!


should it look like this without the status cloud in my main domain



Add another CNAME record:

@ ->

And turn on orange cloud for it as well.


can u send me screenshot on how to add CNAME


Add it the same way you have added the previous record


this problem is killing me

my domain name is parked do i need to point it or it should work like this cuz the problem still not fixed


and i cant use dns in freenom cuz am using custom nameserver


Hi @AwadGorg
Yes you have to set custom ns in freenom


if i set custom server in freenom i cant set dns


Don’t use dns. Only use custom NS


do you know away to set up cloudflary with custom ns


Yes you have to put the ns that are given to you by cloud flare. Just put those nameservers in your custom ns


check the image above my freenom domain dosnt have that orange cloud like the subdomain


and the type is not CNAME ITS MX if i contuine with this does my will work throw cloudflare as well


I think you are in confusion so follow these two tutorials correctly. They will obviously solve your all confusions. :slight_smile: