New member here.
First post.
Yesterday, site is fine.
Wake up today to this:

Problem loading page
Secure Connection Failed

An error occurred during a connection to Peer’s Certificate has been revoked. Error code: SEC_ERROR_REVOKED_CERTIFICATE

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

Learn more…

Report errors like this to help Mozilla identify and block malicious sites

Can someone steer me in the direction I need to go in to fix this? Thank you.

HTTPS/SSL error issues [MAIN THREAD]

I got this error too.


Just today you are getting this error?


I just registered my account and deployed word press today.

I can access to the site in my office.

But I failed to connect to it at home.


Sorry to hear that.
Probably same problem as me then.
Thank you for confirming.
Now I guess we wait…


Are you by chance using firefox browser also?
I just found a work around to access my site until the issue is fixed.
I can share with you if you would like…


Same problem as well.


I am having the same issue, as are a bunch of others on this forum. It seems to be specific to Firefox from what I’ve read, I haven’t tested it yet on other browsers. I emailed 000webhost, but they just sent me here. One of the moderators in another topic said to switch browsers, but that doesn’t solve the problem on Firefox, it just diverts it. I hope they get around to fixing it soon or offer advice of how we can fix it.


The work-around for firefox that worked for me is:

-open firefox menu
-click on options
-click on privacy and security
-scroll down and UNCHECK box: Query OCSP responder servers to confirm the current validity of certificates
-Needs to be reversed again after resolution

Again, this is a work-around for firefox until the solution is found.


That doesn’t sound very safe, if you visit any other website you won’t know if the certificate is valid.


That is true. But the issue is with my site, not any other site.


Basically, don’t visit any other websites or let your site access other sites while this is unchecked. Not a long term solution. I asked a moderator to test it with Firefox in another thread, hopefully they will find the issue, but I haven’t heard back yet.


Thank you. Notice how I had included in my post about it being a work-around until the solution was found?


Right, thanks! It’s just a warning to others not to go browsing while using this workaround.


Thanks for workaround.
Issue is reported. Thanks again.