Testing 123 page displayed instead of site


#1

on my site page https://eswebdesign.000webhostapp.com/
it shows the testing 123 message

please help

is this normal?


#2

Hi @amigo !

This is a known issue and admins are working on fixing it. Please be patient and try again after a while.

We are sorry for inconvenience :sweat:


#3

Hi @amigo!

As far as I know, this issue can be overcome if you upload an index.php file to your website.

In other words, just upload your website through File Manager or a FTP client and it should work fine.

Please do reply the results, as I am not sure if this is going to fully work.


#4

I re-uploaded the db, and the site via file manager. I now get this:

The website encountered an unexpected error. Please try again later.

InvalidArgumentException: Class “\Drupal\system\Controller\Http4xxController” does not exist. in Drupal\Core\DependencyInjection\ClassResolver->getInstanceFromDefinition() (line 24 of core/lib/Drupal/Core/DependencyInjection/ClassResolver.php).


#5

Please lower your PHP version and try again: 000webhost cPanel > Settings > General > Change PHP version > 5.6


#6

My site was built on php 7.1.5

I have just tried 5.6 7.0 and 7.1 on your sever and I still get the same message every time


#7

If you have your website DB and your files backed up (on your local PC), go to your cPanel>Settings>General and hit Reset Website


#8

Ok, then change your PHP back to 7.1


#9

just to clarify change to 7.1 on your settings page?


#10

Uhm… yes…

But can the PHP be changed from Drupal configuration? (I have never used Drupal)


#11

dunno, ive uploaded two drupal sites before no problem. Don’t understand?


#12

I think I know what the problem is.

Please create a new PHP script in /public_html and name it testx.php with this content:

<?php

print(phpinfo());

?>

Browse the script and reply what PHP version is being used.


#13

It says 7.1.6

I thought it was 7.1.5


#14

Then this is the main problem.

Our PHP version is not compatible with the one on which Drupal was set up.

I think reading this topic would shed some lights. Maybe help you resolve the problem… :slight_smile: