Upload by saving into network on a computer


#1

Hi!
So I have connected the FTP server of my website to my computer via “add network-adress” (shown in the pic below, hope you understand trough the images and position). And deleting stuff via the explorer works fine! However, when I try to put a file in there and upload it, I get the following error message (it basically says that I don’t have the permission to save files on the server). What can I do against that? I have seen many tutorials, but this one exactly represents my needs. I am thankful for any kind of answer!
error


#2


#3

Can you try an FTP client to see if you get the same error?


#4

@Infinity I am using FileZilla and creating new files works perfectly


#5

Also it’s probably worth noting that I don’t know anything about PHP, JavaScript or node.js.


#6

Hmm.
I can’t see why FileZilla would work and you can’t do it with Explorer.
You could try the “Repair/fix” option in General Settings while logged into 000webhost.com to see if that does anything? :slight_smile:


#7

@Infinity I can totally understand the confusion there. The thing is, I am in the process of writing a program that outputs a .txt file to somewhere on the computer. This app will not be used by me, but by someone who knows nothing about programming and just little about computers in general. The point of that program is to AVOID having to go into FileZilla or the datamanager.


#8

Yep if you try the repair option to see if Explorer starts allowing uploads?


#9

I’ll try. Filling character minimum
Edit: Doens’t seem to work. And it makes sense. I would have to somehow allow anyone to write in my public_html folder. I tried that over the file manager even that didn’t help.


#10

So when you connect it does ask for username and password yeah?


#11

Yup. CHARACTER MINIMUM


#12

What type of files have you tried to upload?


#13

You see, if I right click the “Create new” or “paste in” (or whatever they are calles in english you get what i mean) are grayed out. Well I guess I could create a folder…


#14

OMG. I created a new folder and pasted something into it… it worked! Granted, I still can’t create new stuff but it’s a beginning.


#15

So yeah I’ve managed to connect to FTP, I can pull files onto the explorer window and they upload without issue, if I click new I can only make new folders.


#16

Oh well looks like it works now. At least copying something into it. Creating a text file with a program won’t work probably. (I’ll try it now)
Nah, doesn’t work.


#17

You could use batch scripts to upload a set file to FTP server if you are going to just have set files to upload, then you could just have upload Upload1.bat Upload2.bat on the desktop, click the batch file and it will do the work of connecting and uploading and closing the window afterwards?


#18

Paste into text editor and save as upload.bat (all files)

@ftp -i -s:"%~f0"&GOTO:EOF
open files.000webhost.com
FTPUSER
FTP-PASS
!:--- FTP commands below here ---
lcd C:/Users/Infinity/Desktop/adb/AdbNativeMessaging/Properties
cd  public_html/
binary
mput "*.*"
disconnect
bye

Uploaded all the files inside the folder Properties to my public_html and closed after doing so?


#19

Currently on my phone, but I can’t remember having a properties folder…


#20

No that is my example, change the lcd line to your local directory of files you want uploaded.