Why do I get a 404 while trying to access a subfolder on my domain?


#1

I have a folder called “.well-known” in my public_html folder. Inside it, there’s a sub folder called “acme-challenge”. When I access mydomain.com/.well-known, I can see the “acme-challenge” folder in the directory list but when I try to access “acme-challenge”, a 404 is thrown.

Precisely, for some strange reason, mydomain.com/.well-known is accessible but mydomain.com/.well-known/acme-challenge is not. I have no idea as to why this happening.

Can anyone please help me overcome this situation? I’d be very grateful.

(P.S. I’ve tried clicking on the Fix file permissions button in the website settings but that seems to have had no effect.)
Thanks.
-P.


#2

Can you remove the dot before well-known?


#3

I need the dot. I’m using a third party application that checks for files in the specific directory.


#4

What third party is that?


#5

“Let’s encrypt”. I’m using it to generate an SSL certificate for my site.
I tried removing the dot and it worked but I need the dot.
The dot is a valid character, so why is the subfolder not accessible when the folder name begins with a dot??


#6

Custom SSL certificates are not available on free plans, please use cloudflare for SSL


#7

I understand…but why is the directory problem happening??


#8

Maybe because . Hides the directory, idk


#9

Those folders won’t work on the free hosting for security reasons.