Wide version not showing up when phone version enabled


#1

I’ve had my website up for several months now, but I’ve noticed that when I enable the phone version, the wide version sometimes stops showing up on the desktop browser; it acts like only the phone version is enabled, even though both wide and phone are both enabled.

I can only get the wide version to show up again if I completely disable the phone version. Has anyone else had similar problems with this? This happens with both Safari and Firefox. Thanks.


#2

@lauradamara Can you post screenshot of your issue??


#3

Please see the attached screenshot; this is what it looks like in the Desktop browser when both wide and phone versions are enabled.


#4

@lauradamara You’re talking about your website not being responsive(fit to display) on both phone and desktop at the same time?? Am i right??


#5

Thanks for the response,

When I have both wide and phone versions both set to “on”, the desktop version is not responsive, but the phone version is. That is to say, it looks correct on the phone, but it looks incorrect on the desktop version.


#6

@lauradamara Can you try “Auto Layout”??
image

This should solve your issue. :slight_smile:


#7

I just tried beta; unfortunately the formatting of the phone version on Beta is a total mess: please see the attached screenshots. The desktop version also has issues with the menubar - see third screenshot. I tried to lengthen the menu bar to fix this problem, as it does not look like this in the builder (it looks normal in the builder), but lengthening the menu bar did not do anything.


#8

@lauradamara Your facing issues, because “Auto Layout” is still under testing and development.

@sulliops Can you help??


#9

Right, so I would prefer not to use “Auto Layout.” I would like to use the wide and phone layouts, which are manual. However, when I have both wide and phone versions both set to “on”, the desktop version is not responsive, but the phone version is. That is to say, it looks correct on the phone, but it looks incorrect on the desktop version. Could you please advise on this issue?


#10

@lauradamara @sulliops have good experience with zyro,
I’m waiting for him to reply.


#11

Hey, sorry, I’ve been quite busy as of late.

The Auto Layout feature is indeed in beta, so I wouldn’t suggest using it unless it actually fixes the problem. Regarding the issue with the desktop version, can I ask you to provide some details?

If you can please screenshot which versions of the site you have enabled? If “wide” and “phone” are on, then this is a totally different issue. However, if “wide”, “desktop”, and “phone” (all three) are enabled at once, then I would suggest choosing between wide or desktop and disabling the other, because that has caused issues for me before.


#12

Please see attached screenshots; “wide” and “phone” are on. I have never enabled desktop, so that is not an issue.


#13

Does anyone have any ideas/updates on this issue? I’d really appreciate help, thanks!


#14

What features are currently active on Zyro, still wide and phone?

Looks good on Chrome Windows & Chrome Android at the moment…


#15

Yes, I turned phone version off. I’ve turned it on again, same problem.


#16

My main problem is, I don’t want to leave it with both phone and wide screen enabled for days on end, as it looks very bad for desktop users, so I will turn off the phone portion again until I hear further notice. As I said, however, this is still a major problem I have no idea how to fix - seems like a major error with the system.


#17

I had enabled the phone version and the desktop version. But when browsing on my large 10 inch Tablet at high (1536*2048) resolution I still got the tiny phone version presented as long as I kept my tablet in portrait orientation. Even setting “Desktop Version On” in Chrome didn’t help. Only if I switch to landscape do I get the desktop version presented.

What are the rules on the server side? Which client does it need to see before delivering the desktop version? It seems the phone version is preferred, unless the client reports a very large screen.

Until I find a solution to this, I have chosen to disable the phone version, which is not really satisfactory