Wordpress settings not saving

I have a completely fresh site setup and fresh Wordpress install on it. I have not added any plugins, no themes, nothing.

When I switch off any of options in Wordpress Dashboard \ Settings (for example \ Discussion \ Other comment settings \ Comment author must fill out name and email ) and press [Save Changes] button, the page refreshes and again I see the option still switched on.

This is the same problem as mentioned in topic - see link.
But I do not see the real solution there.

I’ve tested this on multiple browsers, cleared all cache in those browsers, tested on multiple PCs, but the problem still exists.

Any ideas how to solve it?

No idea I have same issue with the topic you linked and we couldn’t solve it so he moved to Hostinger for rest of sites.

I’ve troubleshooted again on your site but I can’t find/see anything causing the issue.

Doesn’t appear to be

.htaccess related
plugin related
theme related
config related

1 Like

Thank you!
seems like this is a problem on 000webhost side and affecting many people … :frowning:
Hopefully someone else can help…
Possible option: cleansing server-side Wordpress cache on 000webhost. But I do not know how to do that.

Hi! We’ve reported the issue to our developers, they should come up with a patch soon :slight_smile:

1 Like

Meanwhile I’ve found a quick workaround.

I’ve added my special-purpose admin menu item which executes one line of code to change the option as I want.

Here is the procedure.

Using any file manager (in my case 000webhos ftp build-in tool) go to the folder of Theme used by your website (in my case public_html>wp-content>themes>twentyseventeen).
There is a file named functions.php.
Just in case of failure create a copy of original functions.php file (in my case the copy is named functions20210202.php).
Edit the file functions.php and at a very end of this file put short code.
This is the code in my case:
//AP20210202 adds admin menu item to perform requested operations
add_action( ‘admin_menu’, ‘register_my_menu_item_AP20210202’ );

function register_my_menu_item_AP20210202() {
    add_menu_page( 'AP20210202 special purpose admin menu item', 'AP20210202 execute programmed actions', 'manage_options', 'query-string-parameter', 'my_menu_item_AP20210202');

function my_menu_item_AP20210202
() {
    echo 'execution started!';
    update_option( 'require_name_email', '0' );
    echo 'execution finished!';

Save the functions.php file.
Go to wp admin menu page (https://YourSiteName.000webhostapp.com/wp-admin/).
Locate just created menu item (in my case named “AP20210202 execute programmed actions”).
Click on this menu item.
This executes part of the code: update_option( ‘require_name_email’, ‘0’ );
And you can verify in admin menu Settings>Discussion that the option “Comment author must fill out name and email” is now unchecked.

I’m not fully happy with this solution, because it’s against many rules, and, in case your Theme provider updates its functions.php file you need to enter the code again.
But it seems to be working.

Nevertheless I count of the community to find root cause why original admin menu doesn’t allow to switch off those options…

This topic was automatically closed after 38 days. New replies are no longer allowed.