WP: redirect from non-www version to www version



i just got a new domain Yesterday named voiqu.com and i chose to host it here with a free account. I put the name servers and everything was going nice till a chose to write in Wordpress Settings at WordPress Address (URL) and Site Address (URL): http://www.voiqu.com (redirect from non-www version to www version)

I tried to modify the .htaccess file but nothing happend. After that i tried to completely reinstall wordpress. I passed the configuration settings (i enterd all mysql data) but when i sopouse to enter in dashbord i got the same error.


I’d click Clean up/Reload Account in members area/CPanel and start again; much easier than trying to fix whatever’s wrong.



i reloaded my account as you suggested and changed again in Wordpress Settings at WordPress Address (URL) and Site Address (URL) to www version of my domain and happend the same thing.

I will probably stick with the non-www version.

Topic can be close

Thank you very much for your replay, have a nice day!



Try that way.


This is the exact way i tried

i think will do the same thing in webmaster tools. Hope that will work there

Thanks again


I still can’t figure out how to make this redirect. In Webmaster Tools i can’t set the preferred domain with html file, nor with meta tag in the head section of my site.
To make things worst, my www version http://www.voiqu.com/ is temporary redirecting (302) to http://error404.000webhost.com/?

Only my non-www version is working properly http://voiqu.com/

Any help will be gladly accepted


Can you not set it back to default? Use both www and non www


I only chaged the .htacces file to make the redirect but with no results.

RewriteEngine On
RewriteCond %{HTTP_HOST} !^my-domain.com$ [NC]
RewriteRule ^(.*)$ http://my-domain.com/$1 [R=301,L]

After that i deleted this lines of code. I saved the file back and this is the result.

Tomorrow will make a backup for my database and theme so i’lll refresh the install