Your website doesn't have "index.php"


I have my website online but I get the message: 'You see this page because your website doesn’t have “index.php” or “index.html” file in public_html folder. '. I do have such a file and the website works in the example site: The file manager shows that the index file is inside the public_html:

Thanks for help.


Add to your .htaccess

DirectoryIndex index.html index.php


I have made the changes. Problem persists. Should these changes take effect immediately?


It’s working here :slight_smile:


JD and coke


I’m still seeing the redirect. Are you viewing or http wwwjdcomplexcom.000webhostapp com?


I am having the same problem, and have tried the workaround suggested by the staff, but my website does not upload on the internet, even when I access it via website builder.

I also make amendments in the website builder and then select “publish” but nothing gets saved.

These issues started to occur in the middle of a session of managing my website in the website builder.


I have exactly the same problem. Looks like an upgrade on the webhost server or something is responsible for this.


I have exactly the same problem


Not at all, you have to add an index file :slight_smile:



That’s a weird one @mantas.daraciunas


I have taken the appropriate action, as shown by the staff above, but I still cannot view my website on the internet


Hi have always used the website builder and never had to add a index.html. It just stopped working. I understand that we have to add the index.html, but how do we do that from the website builder?



your mentioned domain points to app which does not have any index.php or index.html file therefore you are getting this page.



Same applies to you too! domain points to which has no files in the folder.


What do we have to do well for the first time like this?


I think it’s better now :))


@mantas.daraciunas these sites above had fully built Zyro sites when they posted but it was showing the default 000webhost directory page upon visiting their site and connecting via FTP displayed missing Zyro folder and other such symptoms.
I can only assume it was a temporary issue and has resolved/restored itself as the sites appear to be loading now?


I’m not seeing that site anymore live have you changed your nameservers or removed yourself from 000webhost? If you still need help please reply with more information! @serkan_ercan1984


Hi, ckhawand, I have tried adding index.html & index.php to .htaccess but I cannot see how this can be done, please advise