Zoho Mail proplems


#1

I have a domain( randomartdesignz.ga) linked to my 000webhost site, combined with cloudflare and wordpress. I wanted to create a mail ( mail@randomartdesignz.ga) , so i used zohomail. Now i can send mails, but i dont receive mails. I have already add the mx records in cloudflare, but it still dont works. PLS HELP


#2

@helloplayer1 Make sure you have set up ZohoMail correctly.


#3

me works fine with this settings


#4

Hi @helloplayer1!

Turn the orange clouds from MX records on/off at 15 minutes timeot, then try again.


#5

@NGiNX dont have clouds


#6

Oh, I forgot it’s just MX :unamused:


In this case, it depends on how fast the DNS propagates. This process can take up to 24 hours, sometimes even 48.


#7

and be sure is Incoming enabled


#8


#9

It looks like this , i have it set up like i should


#10

Have a look at @1microfix’s tutorial:
How to use Zoho Mail with domain


#11

@helloplayer1 set in name @


#12

It would also be beneficial for you to enable the cloud on the www CNAME record so you get SSL.

In the MX records, it should say @ instead of mail, unless you are going to want your email address to be like email@mail.randomartdesignz.ga, in which case you’ll need to setup Zoho again (which is a pain). It would work best if you just changed those MX records to @.


#13

Already done, and my mx records are now shown in mxtoolbox.com, but zoho still dont find the mx records


#14

Zoho seems to take forever to find them with Cloudflare. Wait up to 24 hours and see what happens - if it still doesn’t recognize the records, let us know.


#15

Temporary disable the Cloudflare protection: turn off all orange clouds from right side, and try again after 10 minutes.


#16

Well, i now receive mails even if it doenst know the mx records, so maybe its no problem.


#17

The MX records appear to be configured properly from here as well. :wink:

If you encounter any issues, please do post back.


#18